aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libxsettings/libxsettings_0.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libxsettings/libxsettings_0.11.bb')
-rw-r--r--recipes/libxsettings/libxsettings_0.11.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/libxsettings/libxsettings_0.11.bb b/recipes/libxsettings/libxsettings_0.11.bb
new file mode 100644
index 0000000000..fc6f452470
--- /dev/null
+++ b/recipes/libxsettings/libxsettings_0.11.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Common code for XSETTINGS"
+SECTION = "gpe/libs"
+LICENSE = "BSD-X"
+PRIORITY = "optional"
+DEPENDS = "virtual/libx11"
+
+PR = "r1"
+
+inherit gpe
+
+headers = "xsettings-common.h"
+
+do_compile_prepend() {
+ sed -i -e 's: -s : :g' Makefile
+}
+
+do_stage () {
+ oe_libinstall -so libXsettings ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/gpe
+ for h in ${headers}; do
+ install -m 0644 ${S}/$h ${STAGING_INCDIR}/$h
+ done
+}
+
+do_install () {
+ gpe_do_install
+ oe_runmake PREFIX=${prefix} DESTDIR=${D} install-devel
+}