aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libtododb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libtododb')
-rw-r--r--recipes/libtododb/libtododb_0.07.bb23
-rw-r--r--recipes/libtododb/libtododb_0.08.bb23
-rw-r--r--recipes/libtododb/libtododb_0.09.bb25
-rw-r--r--recipes/libtododb/libtododb_0.10.bb24
-rw-r--r--recipes/libtododb/libtododb_0.11.bb18
-rw-r--r--recipes/libtododb/libtododb_svn.bb29
6 files changed, 142 insertions, 0 deletions
diff --git a/recipes/libtododb/libtododb_0.07.bb b/recipes/libtododb/libtododb_0.07.bb
new file mode 100644
index 0000000000..c71e5db1e1
--- /dev/null
+++ b/recipes/libtododb/libtododb_0.07.bb
@@ -0,0 +1,23 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Database access for GPE to-do list"
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "libgpewidget libgpepimc sqlite"
+
+inherit pkgconfig gpe
+
+headers = "todo-db.h"
+
+do_stage () {
+ oe_libinstall -so libtododb ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/gpe
+ for h in ${headers}; do
+ install -m 0644 ${S}/gpe/$h ${STAGING_INCDIR}/gpe/$h
+ done
+}
+
+do_install () {
+ gpe_do_install
+ oe_runmake PREFIX=${prefix} DESTDIR=${D} install-devel
+}
diff --git a/recipes/libtododb/libtododb_0.08.bb b/recipes/libtododb/libtododb_0.08.bb
new file mode 100644
index 0000000000..c71e5db1e1
--- /dev/null
+++ b/recipes/libtododb/libtododb_0.08.bb
@@ -0,0 +1,23 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Database access for GPE to-do list"
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "libgpewidget libgpepimc sqlite"
+
+inherit pkgconfig gpe
+
+headers = "todo-db.h"
+
+do_stage () {
+ oe_libinstall -so libtododb ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/gpe
+ for h in ${headers}; do
+ install -m 0644 ${S}/gpe/$h ${STAGING_INCDIR}/gpe/$h
+ done
+}
+
+do_install () {
+ gpe_do_install
+ oe_runmake PREFIX=${prefix} DESTDIR=${D} install-devel
+}
diff --git a/recipes/libtododb/libtododb_0.09.bb b/recipes/libtododb/libtododb_0.09.bb
new file mode 100644
index 0000000000..01fe358085
--- /dev/null
+++ b/recipes/libtododb/libtododb_0.09.bb
@@ -0,0 +1,25 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Database access for GPE to-do list"
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "libgpewidget libgpepimc sqlite"
+
+
+inherit pkgconfig gpe autotools
+
+SRC_URI="${GPE_MIRROR}/${PN}-${PV}.tar.bz2"
+headers = "todo-db.h"
+
+do_stage () {
+ oe_libinstall -so libtododb ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/gpe
+ for h in ${headers}; do
+ install -m 0644 ${S}/gpe/$h ${STAGING_INCDIR}/gpe/$h
+ done
+}
+
+do_install () {
+ gpe_do_install
+# oe_runmake PREFIX=${prefix} DESTDIR=${D} install-devel
+}
diff --git a/recipes/libtododb/libtododb_0.10.bb b/recipes/libtododb/libtododb_0.10.bb
new file mode 100644
index 0000000000..bb6f95a5b1
--- /dev/null
+++ b/recipes/libtododb/libtododb_0.10.bb
@@ -0,0 +1,24 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Database access for GPE to-do list"
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "libgpewidget libgpepimc sqlite"
+
+GPE_TARBALL_SUFFIX = "bz2"
+inherit pkgconfig gpe autotools
+
+headers = "todo-db.h"
+
+do_stage () {
+ oe_libinstall -so libtododb ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/gpe
+ for h in ${headers}; do
+ install -m 0644 ${S}/gpe/$h ${STAGING_INCDIR}/gpe/$h
+ done
+}
+
+do_install () {
+ gpe_do_install
+# oe_runmake PREFIX=${prefix} DESTDIR=${D} install-devel
+}
diff --git a/recipes/libtododb/libtododb_0.11.bb b/recipes/libtododb/libtododb_0.11.bb
new file mode 100644
index 0000000000..7d0bb146e9
--- /dev/null
+++ b/recipes/libtododb/libtododb_0.11.bb
@@ -0,0 +1,18 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Database access for GPE to-do list"
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "libgpewidget libgpepimc sqlite"
+
+GPE_TARBALL_SUFFIX = "bz2"
+inherit pkgconfig gpe autotools
+
+
+do_stage () {
+ autotools_stage_all
+}
+
+do_install () {
+ gpe_do_install
+# oe_runmake PREFIX=${prefix} DESTDIR=${D} install-devel
+}
diff --git a/recipes/libtododb/libtododb_svn.bb b/recipes/libtododb/libtododb_svn.bb
new file mode 100644
index 0000000000..a0263f27ac
--- /dev/null
+++ b/recipes/libtododb/libtododb_svn.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Database access for GPE to-do list"
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "libgpewidget libgpepimc sqlite"
+PV = "0.10+svn${SRCDATE}"
+PR = "r0"
+
+inherit pkgconfig gpe autotools
+
+SRC_URI = "${GPE_SVN}"
+
+S = "${WORKDIR}/${PN}"
+
+do_install () {
+ gpe_do_install
+# oe_runmake PREFIX=${prefix} DESTDIR=${D} install-devel
+}
+do_stage () {
+ oe_libinstall -so libtododb ${STAGING_LIBDIR}
+ mkdir -p ${STAGING_INCDIR}/gpe
+ for h in ${headers}; do
+ install -m 0644 ${S}/gpe/$h ${STAGING_INCDIR}/gpe/$h
+ done
+}
+
+headers = "todo-db.h"
+
+DEFAULT_PREFERENCE = "-1"