aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libnids/libnids_1.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libnids/libnids_1.18.bb')
-rw-r--r--recipes/libnids/libnids_1.18.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/libnids/libnids_1.18.bb b/recipes/libnids/libnids_1.18.bb
new file mode 100644
index 0000000000..cf887457a2
--- /dev/null
+++ b/recipes/libnids/libnids_1.18.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Libnids performs assembly of TCP segments \
+into TCP streams, IP defragmentation, and TCP port \
+scan detection."
+LICENSE = "GPL"
+SECTION = "libs"
+DEPENDS = "libnet-1.0 libpcap"
+PR = "r1"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/libnids/libnids-${PV}.tar.gz \
+ file://configure.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "\
+ --with-libpcap=${STAGING_LIBDIR}/.. \
+ --with-libnet=${STAGING_LIBDIR}/.. \
+"
+EXTRA_OEMAKE = "'install_prefix=${D}'"
+
+do_stage () {
+ install -m 0644 ${S}/src/nids.h ${STAGING_INCDIR}/
+ oe_libinstall -a -C src libnids ${STAGING_LIBDIR}
+}