aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libgtkinput/libgtkinput_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libgtkinput/libgtkinput_svn.bb')
-rw-r--r--recipes/libgtkinput/libgtkinput_svn.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/libgtkinput/libgtkinput_svn.bb b/recipes/libgtkinput/libgtkinput_svn.bb
new file mode 100644
index 0000000000..b8fcc8c26e
--- /dev/null
+++ b/recipes/libgtkinput/libgtkinput_svn.bb
@@ -0,0 +1,18 @@
+LICENSE = "LGPL"
+PV = "0.3+svn${SRCDATE}"
+
+inherit gpe autotools
+
+SRC_URI = "${GPE_SVN} \
+ file://gtkinput.sh"
+
+S = "${WORKDIR}/${PN}"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/X11/Xsession.d
+ install -m 755 ${WORKDIR}/gtkinput.sh ${D}/${sysconfdir}/X11/Xsession.d/46gtkinput
+}
+
+FILES_${PN} += "${libdir}"
+
+DEFAULT_PREFERENCE = "-1"