aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libffi/libffi-native_2.0+gcc4.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libffi/libffi-native_2.0+gcc4.3.2.bb')
-rw-r--r--recipes/libffi/libffi-native_2.0+gcc4.3.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/libffi/libffi-native_2.0+gcc4.3.2.bb b/recipes/libffi/libffi-native_2.0+gcc4.3.2.bb
new file mode 100644
index 0000000000..f0859e963f
--- /dev/null
+++ b/recipes/libffi/libffi-native_2.0+gcc4.3.2.bb
@@ -0,0 +1,30 @@
+require libffi_${PV}.bb
+
+inherit native
+
+EXTRA_OECONF = "--with-gnu-ld \
+ --enable-shared \
+ --enable-target-optspace \
+ --enable-languages=c,c++,f77 \
+ --enable-threads=posix \
+ --disable-multilib \
+ --enable-c99 \
+ --enable-long-long \
+ --enable-symvers=gnu \
+ --program-prefix=${TARGET_PREFIX} \
+ ${EXTRA_OECONF_PATHS}"
+
+ffi_include = "ffi.h ffitarget.h"
+
+install_libffi_headers() {
+ :
+}
+
+do_stage () {
+ oe_libinstall -so -C .libs libffi ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/
+ for i in ${ffi_include}; do
+ install -m 0644 include/$i ${STAGING_INCDIR}/
+ done
+}