aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/junit/junit_3.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/junit/junit_3.8.2.bb')
-rw-r--r--recipes/junit/junit_3.8.2.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/junit/junit_3.8.2.bb b/recipes/junit/junit_3.8.2.bb
new file mode 100644
index 0000000000..2ba54b63a7
--- /dev/null
+++ b/recipes/junit/junit_3.8.2.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "JUnit is a testing framework for Java"
+LICENSES = "CPL"
+AUTHOR = "junit.org"
+HOMEPAGE = "http://www.junit.org"
+
+SRC_URI = "http://downloads.sourceforge.net/junit/junit${PV}.zip"
+
+S = "${WORKDIR}/junit${PV}"
+
+inherit java-library
+
+DEPENDS = "fastjar-native"
+
+do_unpackpost() {
+ mkdir -p src
+
+ # Prevent deletion by do_removebinaries.
+ mv src.jar src.zip
+
+ unzip src.zip -d src
+}
+
+addtask unpackpost before do_removebinaries after do_unpack
+
+do_compile() {
+ mkdir -p build
+
+ # Workaround for jamvm.
+ bcp=${STAGING_DATADIR_NATIVE}/classpath/glibj.zip
+
+ javac -bootclasspath $bcp -sourcepath src -d build `find src -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}