summaryrefslogtreecommitdiffstats
path: root/recipes/ipkg/ipkg_0.99.163.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ipkg/ipkg_0.99.163.bb')
-rw-r--r--recipes/ipkg/ipkg_0.99.163.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/ipkg/ipkg_0.99.163.bb b/recipes/ipkg/ipkg_0.99.163.bb
new file mode 100644
index 0000000000..f546f6e6c8
--- /dev/null
+++ b/recipes/ipkg/ipkg_0.99.163.bb
@@ -0,0 +1,23 @@
+include ipkg.inc
+PR = "r8"
+
+S = "${WORKDIR}/ipkg-${PV}"
+
+SRC_URI = "http://www.handhelds.org/pub/packages/ipkg/ipkg-${PV}.tar.gz \
+ file://ipkg-configure \
+ file://terse.patch;patch=1 \
+ file://is-processing.patch;patch=1 \
+ file://1-pkg-parse--Optimize-inefficient-parsing.patch;patch=1 \
+ file://2-pkg-vec--Optimize-gross-inefficiency.patch;patch=1 \
+ file://lonk-link-name.patch;patch=1 \
+ "
+
+do_stage() {
+ oe_libinstall -so libipkg ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/libipkg/
+ for f in *.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/libipkg/
+ done
+}
+