summaryrefslogtreecommitdiffstats
path: root/recipes/iperf/iperf_2.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/iperf/iperf_2.0.2.bb')
-rw-r--r--recipes/iperf/iperf_2.0.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/iperf/iperf_2.0.2.bb b/recipes/iperf/iperf_2.0.2.bb
new file mode 100644
index 0000000000..28d009ad58
--- /dev/null
+++ b/recipes/iperf/iperf_2.0.2.bb
@@ -0,0 +1,28 @@
+SECTION = "console/network"
+DESCRIPTION = "Iperf is a tool to measure maximum TCP bandwidth, allowing the tuning of various parameters and UDP characteristics"
+HOMEPAGE = "http://dast.nlanr.net/Projects/Iperf/"
+LICENSE = "BSD"
+PR = "r0"
+
+SRC_URI = "http://dast.nlanr.net/Projects/Iperf2.0/iperf-${PV}.tar.gz"
+# file://socketaddr-h-errno.diff;patch=1"
+
+inherit autotools
+
+S="${WORKDIR}/iperf-${PV}"
+
+# --disable-threads is needed on epia/x86 with uclibc
+do_configure() {
+ gnu-configize
+ oe_runconf --exec-prefix=${STAGING_DIR_HOST}${layout_exec_prefix} --disable-threads
+}
+
+do_compile() {
+ cd ${WORKDIR}/iperf-${PV}
+ oe_runmake
+}
+
+do_install() {
+ cd ${WORKDIR}/iperf-${PV}/src
+ oe_runmake DESTDIR=${D} install
+}