summaryrefslogtreecommitdiffstats
path: root/recipes/images/slugos-image.inc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/slugos-image.inc')
-rw-r--r--recipes/images/slugos-image.inc24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/images/slugos-image.inc b/recipes/images/slugos-image.inc
new file mode 100644
index 0000000000..725d1fac61
--- /dev/null
+++ b/recipes/images/slugos-image.inc
@@ -0,0 +1,24 @@
+# This describes a generic SlugOS image, even though the bb file is
+# called 'slugos-image.bb' the distro specific configuration is
+# done in conf/distro/${DISTRO}.conf (which should always include
+# conf/distro/slugos.conf to get the standard settings).
+
+HOMEPAGE = "http://www.nslu2-linux.org"
+
+DEPENDS = "task-slugos"
+IMAGE_INSTALL = "task-slugos"
+
+COMPATIBLE_MACHINE = "nslu2|ixp4xx|sheevaplug"
+
+IMAGE_NAME = "${IMAGE_BASENAME}-${DISTRO_VERSION}"
+IMAGE_FSTYPES = "jffs2 tar.gz"
+IMAGE_DEVICE_TABLES = "files/device_table-slugos.txt"
+IMAGE_LINGUAS = ""
+
+# IMAGE_PREPROCESS_COMMAND is run before making the image. In SlugOS the
+# kernel image is removed from the root file system to recover the space used -
+# SlugOS is assumed to boot from a separate kernel image in flash (not in the
+# root file system), if this is not the case the following must not be done!
+IMAGE_PREPROCESS_COMMAND += "rm ${IMAGE_ROOTFS}/boot/zImage*;"
+
+inherit image