aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/htb-init/htb-init_0.8.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/htb-init/htb-init_0.8.5.bb')
-rw-r--r--recipes/htb-init/htb-init_0.8.5.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/htb-init/htb-init_0.8.5.bb b/recipes/htb-init/htb-init_0.8.5.bb
new file mode 100644
index 0000000000..a70da77746
--- /dev/null
+++ b/recipes/htb-init/htb-init_0.8.5.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "HTB.init is a shell script that allows for easy setup of HTB-based traffic control on Linux."
+HOMEPAGE = "http://sourceforge.net/projects/htbinit"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/htbinit/htb.init-v${PV} \
+ file://htb.init+ingress+predef+verbose.diff;patch=1;pnum=0 \
+ file://htb-basic-verbose.diff;patch=1;pnum=0"
+RRECOMMENDS = "kernel-module-sch-ingress kernel-module-cls-route kernel-module-cls-u32 kernel-module-cls-fw kernel-module-sch-sfq kernel-module-sch-htb"
+RDEPENDS = "iproute2 (>= 2.6.8-r1)"
+
+S="${WORKDIR}"
+
+do_install() {
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${sysconfdir}/htb
+ install -m 755 ${S}/htb.init-v${PV} ${D}${sysconfdir}/init.d/htb
+}