aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hostap/hostap-daemon_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/hostap/hostap-daemon_git.bb')
-rw-r--r--recipes/hostap/hostap-daemon_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/hostap/hostap-daemon_git.bb b/recipes/hostap/hostap-daemon_git.bb
new file mode 100644
index 0000000000..cf0e6e9483
--- /dev/null
+++ b/recipes/hostap/hostap-daemon_git.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "User space daemon for extended IEEE 802.11 management"
+
+require hostap-daemon-0.7.inc
+
+PR = "r0"
+SRCREV = "b8fb017272ed4794339978c9fbc0e74571a44728"
+PV = "0.7.3+0.8.0-rc"
+PR_append = "gitr${SRCPV}"
+FILESPATHPKG =. "hostap-daemon-git:"
+
+DEFAULT_PREFERENCE = "-1"
+
+S = "${WORKDIR}/git/hostapd"
+
+SRC_URI = "git://w1.fi/srv/git/hostap.git;protocol=git \
+ file://defconfig \
+ file://init"
+
+S = "${WORKDIR}/git/hostapd"
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ echo "CFLAGS += -I${STAGING_INCDIR}" >> .config
+ echo "LIBS += -L${STAGING_LIBDIR}" >> .config
+}
+