aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hal/hal_0.5.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/hal/hal_0.5.11.bb')
-rw-r--r--recipes/hal/hal_0.5.11.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/hal/hal_0.5.11.bb b/recipes/hal/hal_0.5.11.bb
new file mode 100644
index 0000000000..3b5888a863
--- /dev/null
+++ b/recipes/hal/hal_0.5.11.bb
@@ -0,0 +1,15 @@
+require hal.inc
+
+PR = "r5"
+
+SRC_URI += " file://hal-right-input-h.patch;patch=1 \
+ file://fix-configure.diff;patch=1 \
+ file://wifi-2.6.27.diff;patch=1"
+
+# The following code finds the right linux/input.h,
+# which also works with external-toolchain/SDK
+do_configure() {
+ linux_input_h=`echo "#include <linux/input.h>" | ${CPP} - | \
+ grep "linux\/input.h" | head -n 1 | awk -F '"' '{print $2}'`
+ autotools_do_configure --with-linux-input-header=${linux_input_h}
+}