aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtksourceview/gtksourceview2_2.9.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gtksourceview/gtksourceview2_2.9.1.bb')
-rw-r--r--recipes/gtksourceview/gtksourceview2_2.9.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/gtksourceview/gtksourceview2_2.9.1.bb b/recipes/gtksourceview/gtksourceview2_2.9.1.bb
new file mode 100644
index 0000000000..f6695ecacd
--- /dev/null
+++ b/recipes/gtksourceview/gtksourceview2_2.9.1.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Portable C library for multiline text editing"
+HOMEPAGE = "http://projects.gnome.org/gtksourceview/"
+LICENSE = "LGPL"
+DEPENDS = "gtk+ libgnomeprint"
+
+PNAME = "gtksourceview"
+
+S = "${WORKDIR}/${PNAME}-${PV}"
+
+inherit gnome pkgconfig lib_package
+
+# overrule SRC_URI from gnome.conf
+SRC_URI = "${GNOME_MIRROR}/${PNAME}/${@gnome_verdir("${PV}")}/${PNAME}-${PV}.tar.bz2"
+
+SRC_URI += " \
+ file://gtk-doc.make \
+"
+
+do_configure_prepend() {
+ cp ${WORKDIR}/gtk-doc.make ${S}/
+ sed -i -e s:docs::g ${S}/Makefile.am
+ echo "EXTRA_DIST = version.xml" > gnome-doc-utils.make
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += " ${datadir}/gtksourceview-2.0"
+