aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtk+
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gtk+')
-rw-r--r--recipes/gtk+/gtk+_2.14.2.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/recipes/gtk+/gtk+_2.14.2.bb b/recipes/gtk+/gtk+_2.14.2.bb
index eb6cc536b9..0289e2ed22 100644
--- a/recipes/gtk+/gtk+_2.14.2.bb
+++ b/recipes/gtk+/gtk+_2.14.2.bb
@@ -1,6 +1,6 @@
require gtk+.inc
-PR = "r4"
+PR = "r5"
DEPENDS += "cairo jasper"
@@ -39,6 +39,16 @@ python populate_packages_prepend () {
bb.data.setVar('PKG_${PN}', 'libgtk-2.0', d)
}
+
+do_stage_append() {
+
+ # this tool is required by gnome-keyring 2.26.0 to get built
+ # it is written in Python and use only Python xml
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 0755 ${S}/gtk/gtk-builder-convert ${STAGING_BINDIR_NATIVE}
+
+}
+
# gail is part of gtk+ since gtk+-2.13.0 (targetting >=GNOME 2.23):
PROVIDES = "virtual/gail"
RPROVIDES_${PN} = "libgailutil18"