aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gsoap
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gsoap')
-rw-r--r--recipes/gsoap/gsoap-native/use-just-built-binary-2.7.13.patch12
-rw-r--r--recipes/gsoap/gsoap-native_2.7.13.bb12
-rw-r--r--recipes/gsoap/gsoap_2.7.13.bb15
-rw-r--r--recipes/gsoap/gsoap_2.7.13.inc15
4 files changed, 54 insertions, 0 deletions
diff --git a/recipes/gsoap/gsoap-native/use-just-built-binary-2.7.13.patch b/recipes/gsoap/gsoap-native/use-just-built-binary-2.7.13.patch
new file mode 100644
index 0000000000..25a8ef0db1
--- /dev/null
+++ b/recipes/gsoap/gsoap-native/use-just-built-binary-2.7.13.patch
@@ -0,0 +1,12 @@
+diff -urN gsoap-2.7.orig/gsoap/wsdl/Makefile.am gsoap-2.7.orig/gsoap/wsdl/Makefile.am
+--- gsoap-2.7.orig/gsoap/wsdl/Makefile.am 2009-03-21 22:24:42.000000000 +0100
++++ gsoap-2.7.orig/gsoap/wsdl/Makefile.am 2009-04-07 11:30:50.000000000 +0200
+@@ -17,7 +17,7 @@ BUILT_SOURCES=$(SOAP_CPP_SRC)
+ # WSDL2H_EXTRA_LIBS=-lssl -lcrypto -lz # defined in configure.in
+
+ $(SOAP_CPP_SRC) : $(SOAPHEADER)
+- $(SOAP) $(SOAP_FLAGS) $(SOAPHEADER)
++ ../src/soapcpp2 $(SOAP_FLAGS) $(SOAPHEADER)
+
+ #LIBS=
+
diff --git a/recipes/gsoap/gsoap-native_2.7.13.bb b/recipes/gsoap/gsoap-native_2.7.13.bb
new file mode 100644
index 0000000000..3ed78d0227
--- /dev/null
+++ b/recipes/gsoap/gsoap-native_2.7.13.bb
@@ -0,0 +1,12 @@
+require gsoap_${PV}.inc
+
+DEPENDS = ""
+
+SRC_URI += "file://use-just-built-binary-2.7.13.patch;patch=1"
+
+inherit native
+
+do_install() {
+ :
+}
+
diff --git a/recipes/gsoap/gsoap_2.7.13.bb b/recipes/gsoap/gsoap_2.7.13.bb
new file mode 100644
index 0000000000..54f89c68fc
--- /dev/null
+++ b/recipes/gsoap/gsoap_2.7.13.bb
@@ -0,0 +1,15 @@
+require gsoap_${PV}.inc
+
+DEPENDS = "gsoap-native"
+
+do_install_append() {
+ install -d ${D}${libdir}
+ for lib in libgsoapssl libgsoapssl++ libgsoap libgsoapck++ libgsoap++ libgsoapck
+ do
+ oe_libinstall -C gsoap $lib ${D}${libdir}
+ done
+}
+
+
+FILES_${PN} = "${bindir}/wsdl2h ${bindir}/soapcpp2"
+FILES_${PN} += "${datadir}"
diff --git a/recipes/gsoap/gsoap_2.7.13.inc b/recipes/gsoap/gsoap_2.7.13.inc
new file mode 100644
index 0000000000..a6fbbb59e2
--- /dev/null
+++ b/recipes/gsoap/gsoap_2.7.13.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "The gSOAP toolkit provides a unique SOAP-to-C/C++ language binding \
+for the development of SOAP Web Services and clients."
+SECTION = "devel"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gsoap2/gsoap_${PV}.tar.gz"
+
+inherit autotools_stage
+
+S = "${WORKDIR}/gsoap-2.7"
+
+PARALLEL_MAKE = ""
+
+EXTRA_OEMAKE = "SOAP=${STAGING_BINDIR_NATIVE}/soapcpp2"
+