aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gsoap/gsoap-native
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gsoap/gsoap-native')
-rw-r--r--recipes/gsoap/gsoap-native/use-just-built-binary.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/gsoap/gsoap-native/use-just-built-binary.patch b/recipes/gsoap/gsoap-native/use-just-built-binary.patch
new file mode 100644
index 0000000000..f7e4811f9e
--- /dev/null
+++ b/recipes/gsoap/gsoap-native/use-just-built-binary.patch
@@ -0,0 +1,19 @@
+---
+ soapcpp2/wsdl/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- gsoap-2.7.orig/soapcpp2/wsdl/Makefile.am
++++ gsoap-2.7/soapcpp2/wsdl/Makefile.am
+@@ -13,11 +13,11 @@ SOAP_CPP_SRC=wsdlC.cpp
+ SOAPHEADER=wsdl.h
+ SOAP_FLAGS=-SC -pwsdl
+ BUILT_SOURCES=$(SOAP_CPP_SRC)
+
+ $(SOAP_CPP_SRC) : $(SOAPHEADER)
+- $(SOAP) $(SOAP_FLAGS) $(SOAPHEADER)
++ ../src/soapcpp2 $(SOAP_FLAGS) $(SOAPHEADER)
+
+ #LIBS=
+
+ bin_PROGRAMS=wsdl2h
+