aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpephone/libsettings_0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpephone/libsettings_0.3.bb')
-rw-r--r--recipes/gpephone/libsettings_0.3.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/gpephone/libsettings_0.3.bb b/recipes/gpephone/libsettings_0.3.bb
new file mode 100644
index 0000000000..22f8c4f3e0
--- /dev/null
+++ b/recipes/gpephone/libsettings_0.3.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "G(PE)^2 settings API library"
+SECTION = "gpe/libs"
+PRIORITY = "required"
+LICENSE = "LiPS"
+DEPENDS = "glib-2.0 gconf-dbus"
+
+inherit gpephone pkgconfig autotools
+
+FILES_${PN} += " ${libdir}/*.so.*"
+FILES_${PN}-dbg += "${libdir}/.debug/*.so.*"
+FILES_${PN}-dev += "${includedir} ${libdir}/*.la ${libdir}/*.so"
+
+do_stage () {
+ autotools_stage_all
+}