aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpephone/libgemwidget_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpephone/libgemwidget_0.1.bb')
-rw-r--r--recipes/gpephone/libgemwidget_0.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/gpephone/libgemwidget_0.1.bb b/recipes/gpephone/libgemwidget_0.1.bb
new file mode 100644
index 0000000000..0b670e485d
--- /dev/null
+++ b/recipes/gpephone/libgemwidget_0.1.bb
@@ -0,0 +1,17 @@
+LICENSE = "LiPS"
+DESCRIPTION = "Extended widget library for GPE phone environment."
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "gtk+ libiac libgpephone"
+PR = "r1"
+
+GPE_TARBALL_SUFFIX = "bz2"
+inherit gpephone pkgconfig autotools
+
+# This really is not angstrom specific, but gtk 2.10 specific
+# for a better solution: "patches accepted"
+SRC_URI_append_angstrom = " file://gemfilechooser-NULL-callback.patch;patch=1"
+
+do_stage () {
+ autotools_stage_all
+}