aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpephone/libchenabler_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpephone/libchenabler_0.1.bb')
-rw-r--r--recipes/gpephone/libchenabler_0.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/gpephone/libchenabler_0.1.bb b/recipes/gpephone/libchenabler_0.1.bb
new file mode 100644
index 0000000000..cbd28da249
--- /dev/null
+++ b/recipes/gpephone/libchenabler_0.1.bb
@@ -0,0 +1,22 @@
+LICENSE = "LiPS"
+DESCRIPTION = "LiPS voice call library."
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "glib-2.0 sqlite3 librecord"
+PR = "r2"
+
+GPE_TARBALL_SUFFIX = "gz"
+
+inherit gpephone pkgconfig autotools
+
+SRC_URI += "file://po.patch;patch=1"
+FILES_${PN} += " ${datadir}/vochistory"
+
+do_configure_prepend () {
+ mkdir "${S}/po"
+ touch "${S}/po/POTFILES.in"
+}
+
+do_stage () {
+ autotools_stage_all
+}