aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-package/gpe-package_0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-package/gpe-package_0.4.bb')
-rw-r--r--recipes/gpe-package/gpe-package_0.4.bb27
1 files changed, 14 insertions, 13 deletions
diff --git a/recipes/gpe-package/gpe-package_0.4.bb b/recipes/gpe-package/gpe-package_0.4.bb
index 7cdea0b148..1188843101 100644
--- a/recipes/gpe-package/gpe-package_0.4.bb
+++ b/recipes/gpe-package/gpe-package_0.4.bb
@@ -1,25 +1,26 @@
-LICENSE = "GPL"
-PR = "r0"
-inherit gpe pkgconfig
-
DESCRIPTION = "A package manager GUI for GPE"
-DEPENDS = "ipkg libpcre libgpewidget"
-RDEPENDS = "gpe-icons gpe-su"
SECTION = "gpe"
PRIORITY = "optional"
+LICENSE = "GPLv2+"
-SRC_URI += " file://sbin-and-no-suid-install.patch;patch=1 \
- file://gpe-package"
+DEPENDS = "libipkg libpcre libgpewidget"
-FILES_${PN} += " /usr/bin/gpe-package"
+PR = "r3"
+
+inherit gpe pkgconfig
+
+SRC_URI += " file://sbin-and-no-suid-install.patch \
+ file://gpe-package"
+SRC_URI[md5sum] = "f131eed187483620916b7e624b9e3367"
+SRC_URI[sha256sum] = "a1fbdb1e8357b0b2362df9ee457c90dcaafbe7a11723117cb0cbee1ea0f6315c"
CFLAGS += "-DENABLE_PCRE"
LDFLAGS += "-lpcre"
do_install_append() {
- install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/gpe-package ${D}${bindir}
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/gpe-package ${D}${bindir}
}
-SRC_URI[md5sum] = "f131eed187483620916b7e624b9e3367"
-SRC_URI[sha256sum] = "a1fbdb1e8357b0b2362df9ee457c90dcaafbe7a11723117cb0cbee1ea0f6315c"
+RDEPENDS_${PN} = "gpe-icons gpe-su"
+FILES_${PN} += " /usr/bin/gpe-package"