aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-bootsplash/gpe-bootsplash_1.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-bootsplash/gpe-bootsplash_1.14.bb')
-rw-r--r--recipes/gpe-bootsplash/gpe-bootsplash_1.14.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/gpe-bootsplash/gpe-bootsplash_1.14.bb b/recipes/gpe-bootsplash/gpe-bootsplash_1.14.bb
new file mode 100644
index 0000000000..414041dbcb
--- /dev/null
+++ b/recipes/gpe-bootsplash/gpe-bootsplash_1.14.bb
@@ -0,0 +1,22 @@
+inherit gpe
+
+DEPENDS = "gtk+ libsvg-cairo"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r6"
+
+SRC_URI += "file://splash-p.svg file://splash-l.svg \
+ file://c7x0-rotation.patch;patch=1 \
+ file://cxx0-rotation.patch;patch=1 \
+ file://cairofix.patch;patch=1"
+SRC_URI_append_mnci = " file://mnci.patch;patch=1"
+
+FILES_${PN} += "${datadir}/gpe"
+
+do_install_append() {
+ install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-p.svg
+ install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-l.svg
+ mv ${D}${sysconfdir}/rcS.d/S00bootsplash ${D}${sysconfdir}/rcS.d/S03bootsplash
+}
+