aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-bootsplash/gpe-bootsplash-theme-gpephone.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-bootsplash/gpe-bootsplash-theme-gpephone.bb')
-rw-r--r--recipes/gpe-bootsplash/gpe-bootsplash-theme-gpephone.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/gpe-bootsplash/gpe-bootsplash-theme-gpephone.bb b/recipes/gpe-bootsplash/gpe-bootsplash-theme-gpephone.bb
new file mode 100644
index 0000000000..c170746e79
--- /dev/null
+++ b/recipes/gpe-bootsplash/gpe-bootsplash-theme-gpephone.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "A GPE Phone Edition theme for gpe-bootsplash"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "LiPS"
+DEPENDS = "gpe-bootsplash"
+RDEPENDS = "gpe-bootsplash"
+PR = "r0"
+
+export THEME = "gpephone"
+
+SRC_URI = "file://splash-${THEME}-portrait.svg \
+ file://splash-${THEME}-landscape.svg"
+
+do_install() {
+ install -d "${D}${datadir}/gpe"
+ install -m 0644 ${WORKDIR}/splash-${THEME}* ${D}${datadir}/gpe
+}
+
+pkg_postinst() {
+ update-alternatives --install /usr/share/gpe/splash-l.svg bootsplash-l /usr/share/gpe/splash-${THEME}-landscape.svg 20
+ update-alternatives --install /usr/share/gpe/splash-p.svg bootsplash-p /usr/share/gpe/splash-${THEME}-portrait.svg 20
+}
+
+pkg_postrm() {
+ update-alternatives --remove bootsplash-l /usr/share/gpe/splash-${THEME}-landscape.svg
+ update-alternatives --remove bootsplash-p /usr/share/gpe/splash-${THEME}-portrait.svg
+}
+
+FILES_${PN} = "/usr/share/gpe/splash-${THEME}-*"