summaryrefslogtreecommitdiffstats
path: root/recipes/gob2/gob2_2.0.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gob2/gob2_2.0.14.bb')
-rw-r--r--recipes/gob2/gob2_2.0.14.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/gob2/gob2_2.0.14.bb b/recipes/gob2/gob2_2.0.14.bb
new file mode 100644
index 0000000000..eca8d13795
--- /dev/null
+++ b/recipes/gob2/gob2_2.0.14.bb
@@ -0,0 +1,17 @@
+LICENSE = "LGPL"
+DESCRIPTION = "A library to make creating GObjects easier"
+HOMEPAGE = "http://www.5z.com/jirka/gob.html"
+SECTION = "libs"
+DEPENDS = "gtk+ bison flex"
+SRC_URI = "http://ftp.5z.com/pub/gob/old/gob2-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_compile_prepend() {
+ find ${S} -name Makefile | xargs sed -i 's~-I/usr/include~-I${STAGING_INCDIR}~g'
+ find ${S} -name Makefile | xargs sed -i 's~-I$(includedir)~-I${STAGING_INCDIR}~g'
+}
+
+do_stage_append() {
+ install -m 0644 ${S}/gob2.m4 ${STAGING_DATADIR}/aclocal
+}