aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gmu/files/unknown.mk
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gmu/files/unknown.mk')
-rw-r--r--recipes/gmu/files/unknown.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes/gmu/files/unknown.mk b/recipes/gmu/files/unknown.mk
new file mode 100644
index 0000000000..ce3a5c4b7f
--- /dev/null
+++ b/recipes/gmu/files/unknown.mk
@@ -0,0 +1,12 @@
+DECODERS_TO_BUILD=decoders/vorbis.so decoders/flac.so decoders/mpg123.so
+FRONTENDS_TO_BUILD=frontends/sdl.so frontends/log.so
+CC=$(CC)
+CXX=$(CPP)
+STRIP=$(STRIP)
+DEVICE=UNKNOWN_SYSTEM
+
+SDL_LIB=$(shell sdl-config --libs)
+SDL_CFLAGS=$(shell sdl-config --cflags)
+
+INCS=$(CFLAGS) $(SDL_CFLAGS) -fsigned-char -D_REENTRANT -DUSE_MEMORY_H -D_$(DEVICE)
+LIBS=$(LDFLAGS) $(SDL_LIB) -lSDL_image -lSDL_gfx -ldl -Wl,-export-dynamic