aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone')
-rw-r--r--recipes/freesmartphone/dbus-hlid_git.bb3
-rw-r--r--recipes/freesmartphone/frameworkd/oeventsd-use-opimd-signals.patch27
-rw-r--r--recipes/freesmartphone/frameworkd_git.bb11
-rw-r--r--recipes/freesmartphone/fso-abyss_git.bb3
-rw-r--r--recipes/freesmartphone/fso-apm_git.bb3
-rw-r--r--recipes/freesmartphone/fso-gpsd_git.bb3
-rw-r--r--recipes/freesmartphone/fso-gsm0710muxd_git.bb3
-rw-r--r--recipes/freesmartphone/fso-monitord_git.bb3
-rw-r--r--recipes/freesmartphone/fso-sounds.bb3
-rw-r--r--recipes/freesmartphone/fso-specs_git.bb3
-rw-r--r--recipes/freesmartphone/fso-term_git.bb3
-rw-r--r--recipes/freesmartphone/fsodatad_git.bb2
-rw-r--r--recipes/freesmartphone/fsodeviced_git.bb2
-rw-r--r--recipes/freesmartphone/fsogsmd_git.bb3
-rw-r--r--recipes/freesmartphone/fsolocationd_git.bb3
-rw-r--r--recipes/freesmartphone/fsomusicd_git.bb2
-rw-r--r--recipes/freesmartphone/fsonetworkd_git.bb3
-rw-r--r--recipes/freesmartphone/fsotimed_git.bb3
-rw-r--r--recipes/freesmartphone/fsousaged_git.bb3
-rw-r--r--recipes/freesmartphone/gsmd2_git.bb3
-rw-r--r--recipes/freesmartphone/illume-theme-freesmartphone_git.bb3
-rw-r--r--recipes/freesmartphone/libeflvala_git.bb15
-rw-r--r--recipes/freesmartphone/libframeworkd-glib_git.bb3
-rw-r--r--recipes/freesmartphone/libfso-glib_git.bb3
-rw-r--r--recipes/freesmartphone/libfsobasics_git.bb3
-rw-r--r--recipes/freesmartphone/libfsoframework_git.bb3
-rw-r--r--recipes/freesmartphone/libfsoresource_git.bb3
-rw-r--r--recipes/freesmartphone/libfsotransport_git.bb3
-rw-r--r--recipes/freesmartphone/libgsm0710_git.bb3
-rw-r--r--recipes/freesmartphone/libgsm0710mux_git.bb3
-rw-r--r--recipes/freesmartphone/libpersistence_git.bb3
-rw-r--r--recipes/freesmartphone/mickeydbus_git.bb3
-rw-r--r--recipes/freesmartphone/mickeyterm_git.bb3
-rw-r--r--recipes/freesmartphone/multicat_git.bb3
-rw-r--r--recipes/freesmartphone/opimd-utils_git.bb45
-rw-r--r--recipes/freesmartphone/pycd_git.bb3
-rw-r--r--recipes/freesmartphone/vala-dbus-binding-tool-native_git.bb3
-rw-r--r--recipes/freesmartphone/zhone_git.bb3
38 files changed, 133 insertions, 64 deletions
diff --git a/recipes/freesmartphone/dbus-hlid_git.bb b/recipes/freesmartphone/dbus-hlid_git.bb
index 508cf874c6..b0a5f629bc 100644
--- a/recipes/freesmartphone/dbus-hlid_git.bb
+++ b/recipes/freesmartphone/dbus-hlid_git.bb
@@ -4,7 +4,8 @@ AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
SECTION = "console/network"
DEPENDS = "vala-native dbus dbus-glib"
LICENSE = "GPL"
-PV = "1.0.1+gitr${SRCREV}"
+PV = "1.0.1+gitr${SRCPV}"
+PE = "1"
PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/dbus-hlid.git;protocol=git;branch=master"
diff --git a/recipes/freesmartphone/frameworkd/oeventsd-use-opimd-signals.patch b/recipes/freesmartphone/frameworkd/oeventsd-use-opimd-signals.patch
new file mode 100644
index 0000000000..4dc5dd3a84
--- /dev/null
+++ b/recipes/freesmartphone/frameworkd/oeventsd-use-opimd-signals.patch
@@ -0,0 +1,27 @@
+--- a/framework/subsystems/oeventsd/fso_triggers.py 2009-07-12 13:44:53.000000000 +0200
++++ b/framework/subsystems/oeventsd/fso_triggers.py 2009-07-12 13:42:43.000000000 +0200
+@@ -197,8 +197,7 @@
+ class IncomingMessageTrigger(DBusTrigger):
+ #============================================================================#
+ """
+- A custom dbus trigger for org.freesmartphone.GSM.SIM.IncomingStoredMessage
+- TODO: change to opimd interface
++ A custom dbus trigger for org.freesmartphone.PIM.Messages.IncomingMessage
+ """
+
+ function_name = 'IncomingMessage'
+@@ -207,10 +206,10 @@
+ bus = dbus.SystemBus()
+ super(IncomingMessageTrigger, self).__init__(
+ bus,
+- 'org.freesmartphone.ogsmd',
+- '/org/freesmartphone/GSM/Device',
+- 'org.freesmartphone.GSM.SIM',
+- 'IncomingStoredMessage'
++ 'org.freesmartphone.opimd',
++ '/org/freesmartphone/PIM/Messages',
++ 'org.freesmartphone.PIM.Messages',
++ 'IncomingMessage'
+ )
+ def on_signal(self, index):
+ logger.info("Receive IncomingMessage on index = %s" % index)
diff --git a/recipes/freesmartphone/frameworkd_git.bb b/recipes/freesmartphone/frameworkd_git.bb
index 130fe55231..9059c608ca 100644
--- a/recipes/freesmartphone/frameworkd_git.bb
+++ b/recipes/freesmartphone/frameworkd_git.bb
@@ -1,11 +1,12 @@
DESCRIPTION = "The reference implementation of the freesmartphone.org framework APIs"
HOMEPAGE = "http://www.freesmartphone.org"
-AUTHOR = "FreeSmartphone.Org Development Team"
+AUTHOR = "freesmartphone.org Development Team"
SECTION = "console/network"
-DEPENDS = "python-cython-native python-pyrex-native"
+#DEPENDS = "python-cython-native python-pyrex-native"
LICENSE = "GPL"
-PV = "0.9.5.9+gitr${SRCREV}"
+PV = "0.9.5.9+gitr${SRCPV}"
PR = "r0"
+PE = "1"
inherit distutils update-rc.d
@@ -16,6 +17,8 @@ SRC_URI = "${FREESMARTPHONE_GIT}/framework.git;protocol=git;branch=master \
file://frameworkd \
file://frameworkd.conf \
"
+SRC_URI_append_shr = "file://oeventsd-use-opimd-signals.patch;patch=1"
+
S = "${WORKDIR}/git"
do_configure_append() {
@@ -55,6 +58,8 @@ RDEPENDS_${PN} += "\
RRECOMMENDS_${PN} += "\
alsa-utils-amixer \
python-gst \
+ python-phoneutils \
+ python-vobject \
ppp \
"
diff --git a/recipes/freesmartphone/fso-abyss_git.bb b/recipes/freesmartphone/fso-abyss_git.bb
index 4a9126e75c..d4ed6027fc 100644
--- a/recipes/freesmartphone/fso-abyss_git.bb
+++ b/recipes/freesmartphone/fso-abyss_git.bb
@@ -4,7 +4,8 @@ AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
SECTION = "console/network"
DEPENDS = "vala-native dbus dbus-glib libgsm0710mux"
LICENSE = "GPL"
-PV = "0.9.0+gitr${SRCREV}"
+PV = "0.9.0+gitr${SRCPV}"
+PE = "1"
PR = "r0"
SRC_URI = "\
diff --git a/recipes/freesmartphone/fso-apm_git.bb b/recipes/freesmartphone/fso-apm_git.bb
index bb36e7f7fb..8fab71e45e 100644
--- a/recipes/freesmartphone/fso-apm_git.bb
+++ b/recipes/freesmartphone/fso-apm_git.bb
@@ -3,9 +3,10 @@ AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "console"
LICENSE = "GPLv2"
+PE = "1"
DEPENDS = "vala-native"
RCONFLICTS = "apm"
-PV = "2.0.0+gitr${SRCREV}"
+PV = "2.0.0+gitr${SRCPV}"
PR = "r1"
SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git;branch=master"
diff --git a/recipes/freesmartphone/fso-gpsd_git.bb b/recipes/freesmartphone/fso-gpsd_git.bb
index cde1bb65e3..80aba302ba 100644
--- a/recipes/freesmartphone/fso-gpsd_git.bb
+++ b/recipes/freesmartphone/fso-gpsd_git.bb
@@ -2,7 +2,8 @@ DESCRIPTION = "freesmartphone.org gpsd compatibility daemon"
LICENSE = "GPL"
SECTION = "network"
DEPENDS = "dbus-glib"
-PV = "0.8+gitr${SRCREV}"
+PV = "0.8+gitr${SRCPV}"
+PE = "1"
PR = "r2"
SRC_URI = "\
diff --git a/recipes/freesmartphone/fso-gsm0710muxd_git.bb b/recipes/freesmartphone/fso-gsm0710muxd_git.bb
index 5ce1d1e846..e859be26ff 100644
--- a/recipes/freesmartphone/fso-gsm0710muxd_git.bb
+++ b/recipes/freesmartphone/fso-gsm0710muxd_git.bb
@@ -3,7 +3,8 @@ HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/gs
SECTION = "console/network"
DEPENDS = "dbus dbus-glib"
LICENSE = "GPL"
-PV = "0.9.3.1+gitr${SRCREV}"
+PV = "0.9.3.1+gitr${SRCPV}"
+PE = "1"
PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/gsm0710muxd.git;protocol=git;branch=master"
diff --git a/recipes/freesmartphone/fso-monitord_git.bb b/recipes/freesmartphone/fso-monitord_git.bb
index 80668015c3..52cc77972b 100644
--- a/recipes/freesmartphone/fso-monitord_git.bb
+++ b/recipes/freesmartphone/fso-monitord_git.bb
@@ -3,7 +3,8 @@ AUTHOR = "freesmartphone.org development team"
SECTION = "console/network"
DEPENDS = "vala-native dbus dbus-glib"
LICENSE = "GPL"
-PV = "0.0.0+gitr${SRCREV}"
+PV = "0.0.0+gitr${SRCPV}"
+PE = "1"
PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/fso-monitord.git;protocol=git;branch=master"
diff --git a/recipes/freesmartphone/fso-sounds.bb b/recipes/freesmartphone/fso-sounds.bb
index 3277692c57..7fa1a393d9 100644
--- a/recipes/freesmartphone/fso-sounds.bb
+++ b/recipes/freesmartphone/fso-sounds.bb
@@ -1,7 +1,8 @@
DESCRIPTION = "A set of notification sounds"
LICENSE = "CC"
SECTION = "multimedia"
-PV = "0.0.1+gitr${SRCREV}"
+PV = "0.0.1+gitr${SRCPV}"
+PE = "1"
PR = "r2"
SRC_URI = "\
diff --git a/recipes/freesmartphone/fso-specs_git.bb b/recipes/freesmartphone/fso-specs_git.bb
index b346fb54cb..14c7f1f2be 100644
--- a/recipes/freesmartphone/fso-specs_git.bb
+++ b/recipes/freesmartphone/fso-specs_git.bb
@@ -3,7 +3,8 @@ AUTHOR = "Michael 'Mickey' Lauer"
HOMEPAGE = "http://docs.freesmartphone.org"
LICENSE = "BSD"
SECTION = "devel/specifications"
-PV = "0.0.1-gitr${SRCREV}"
+PV = "0.0.1+gitr${SRCPV}"
+PE = "1"
PR = "r2"
SRC_URI = "${FREESMARTPHONE_GIT}/specs.git;protocol=git;branch=master"
diff --git a/recipes/freesmartphone/fso-term_git.bb b/recipes/freesmartphone/fso-term_git.bb
index acb20cdb05..79f042ad41 100644
--- a/recipes/freesmartphone/fso-term_git.bb
+++ b/recipes/freesmartphone/fso-term_git.bb
@@ -4,7 +4,8 @@ AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
SECTION = "console/network"
DEPENDS = "dbus dbus-glib readline libfsoframework"
LICENSE = "GPL"
-PV = "0.0.0.0+gitr${SRCREV}"
+PV = "0.0.0.0+gitr${SRCPV}"
+PE = "1"
PR = "r0"
SRC_URI = "\
diff --git a/recipes/freesmartphone/fsodatad_git.bb b/recipes/freesmartphone/fsodatad_git.bb
index de13bedc0a..cb2913291c 100644
--- a/recipes/freesmartphone/fsodatad_git.bb
+++ b/recipes/freesmartphone/fsodatad_git.bb
@@ -1,6 +1,6 @@
require cornucopia.inc
inherit fso-plugin
PR = "${INC_PR}.0"
-PV = "0.0.0+gitr${SRCREV}"
+PV = "0.0.0+gitr${SRCPV}"
DEPENDS += "libxml2 mobile-broadband-provider-info"
diff --git a/recipes/freesmartphone/fsodeviced_git.bb b/recipes/freesmartphone/fsodeviced_git.bb
index 2516c89aff..7dc1b4fdd3 100644
--- a/recipes/freesmartphone/fsodeviced_git.bb
+++ b/recipes/freesmartphone/fsodeviced_git.bb
@@ -4,7 +4,7 @@ inherit fso-plugin
DEPENDS += "alsa-lib libcanberra libfsoresource"
RDEPENDS += "libcanberra-alsa"
RRECOMMENDS += "fso-alsa-data"
-PV = "0.9.0+gitr${SRCREV}"
+PV = "0.9.0+gitr${SRCPV}"
PE = "1"
PR = "${INC_PR}.6"
diff --git a/recipes/freesmartphone/fsogsmd_git.bb b/recipes/freesmartphone/fsogsmd_git.bb
index 9186ab990b..0d627baa47 100644
--- a/recipes/freesmartphone/fsogsmd_git.bb
+++ b/recipes/freesmartphone/fsogsmd_git.bb
@@ -1,6 +1,7 @@
require cornucopia.inc
inherit fso-plugin
PR = "${INC_PR}.0"
-PV = "0.2.0+gitr${SRCREV}"
+PV = "0.2.0+gitr${SRCPV}"
+PE = "1"
DEPENDS += "libfsoresource libgsm0710mux"
diff --git a/recipes/freesmartphone/fsolocationd_git.bb b/recipes/freesmartphone/fsolocationd_git.bb
index a70bf596f5..2046be7a93 100644
--- a/recipes/freesmartphone/fsolocationd_git.bb
+++ b/recipes/freesmartphone/fsolocationd_git.bb
@@ -1,6 +1,7 @@
require cornucopia.inc
inherit fso-plugin
PR = "${INC_PR}.0"
-PV = "0.0.0+gitr${SRCREV}"
+PV = "0.0.0+gitr${SRCPV}"
+PE = "1"
DEPENDS += "libfsotransport libfsoresource"
diff --git a/recipes/freesmartphone/fsomusicd_git.bb b/recipes/freesmartphone/fsomusicd_git.bb
index 0081298909..443d45ef89 100644
--- a/recipes/freesmartphone/fsomusicd_git.bb
+++ b/recipes/freesmartphone/fsomusicd_git.bb
@@ -1,6 +1,6 @@
require cornucopia.inc
DEPENDS += "gstreamer"
-PV = "0.0.1+gitr${SRCREV}"
+PV = "0.0.1+gitr${SRCPV}"
PR = "${INC_PR}.0"
RDEPENDS += "\
diff --git a/recipes/freesmartphone/fsonetworkd_git.bb b/recipes/freesmartphone/fsonetworkd_git.bb
index 002624fc2b..14b62a991d 100644
--- a/recipes/freesmartphone/fsonetworkd_git.bb
+++ b/recipes/freesmartphone/fsonetworkd_git.bb
@@ -1,5 +1,6 @@
require cornucopia.inc
inherit fso-plugin
DEPENDS += "libnl2"
-PV = "0.1.0.0+gitr${SRCREV}"
+PV = "0.1.0.0+gitr${SRCPV}"
+PE = "1"
PR = "${INC_PR}.0"
diff --git a/recipes/freesmartphone/fsotimed_git.bb b/recipes/freesmartphone/fsotimed_git.bb
index 3c789ad46c..65874de626 100644
--- a/recipes/freesmartphone/fsotimed_git.bb
+++ b/recipes/freesmartphone/fsotimed_git.bb
@@ -1,4 +1,5 @@
require cornucopia.inc
inherit fso-plugin
-PV = "0.1.0+gitr${SRCREV}"
+PV = "0.1.0+gitr${SRCPV}"
+PE = "1"
PR = "${INC_PR}.0"
diff --git a/recipes/freesmartphone/fsousaged_git.bb b/recipes/freesmartphone/fsousaged_git.bb
index a7e4a1c0ee..d14b233ff6 100644
--- a/recipes/freesmartphone/fsousaged_git.bb
+++ b/recipes/freesmartphone/fsousaged_git.bb
@@ -1,4 +1,5 @@
require cornucopia.inc
inherit fso-plugin
-PV = "0.9.0.1+gitr${SRCREV}"
+PV = "0.9.0.1+gitr${SRCPV}"
+PE = "1"
PR = "${INC_PR}.0"
diff --git a/recipes/freesmartphone/gsmd2_git.bb b/recipes/freesmartphone/gsmd2_git.bb
index 4d25aa94e9..8f14bc9141 100644
--- a/recipes/freesmartphone/gsmd2_git.bb
+++ b/recipes/freesmartphone/gsmd2_git.bb
@@ -4,7 +4,8 @@ AUTHOR = "Ixonos Team"
SECTION = "console/network"
DEPENDS = "dbus dbus-glib"
LICENSE = "GPL"
-PV = "0.1.0+gitr${SRCREV}"
+PV = "0.1.0+gitr${SRCPV}"
+PE = "1"
PR = "r1"
SRC_URI = "${FREESMARTPHONE_GIT}/gsmd2.git;protocol=git;branch=master"
diff --git a/recipes/freesmartphone/illume-theme-freesmartphone_git.bb b/recipes/freesmartphone/illume-theme-freesmartphone_git.bb
index 1351674a18..c9f50f503c 100644
--- a/recipes/freesmartphone/illume-theme-freesmartphone_git.bb
+++ b/recipes/freesmartphone/illume-theme-freesmartphone_git.bb
@@ -2,7 +2,8 @@ DESCRIPTION = "Illume theme for the freesmartphone.org project"
HOMEPAGE = "http://illume.projects.openmoko.org/"
LICENSE = "MIT/BSD"
DEPENDS = "edje-native eet-native"
-PV = "0.1.0+gitr${SRCREV}"
+PV = "0.1.0+gitr${SRCPV}"
+PE = "1"
PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/artwork.git;protocol=git;branch=master"
diff --git a/recipes/freesmartphone/libeflvala_git.bb b/recipes/freesmartphone/libeflvala_git.bb
deleted file mode 100644
index 9040bbd10a..0000000000
--- a/recipes/freesmartphone/libeflvala_git.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-DESCRIPTION = "Vala meets the Enlightenment Foundation Libraries"
-AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-LICENSE = "LGPL"
-SECTION = "devel"
-DEPENDS = "vala-native glib-2.0 dbus dbus-glib eina eet evas ecore edje elementary"
-PV = "0.0.1.0+gitr${SRCREV}"
-PR = "r0"
-
-SRC_URI = "${FREESMARTPHONE_GIT}/libeflvala;protocol=git;branch=master"
-S = "${WORKDIR}/git"
-
-inherit autotools_stage pkgconfig vala
-
-PACKAGES =+ "${PN}-examples"
-FILES_${PN}-examples = "${datadir}/libeflvala ${bindir}/*"
diff --git a/recipes/freesmartphone/libframeworkd-glib_git.bb b/recipes/freesmartphone/libframeworkd-glib_git.bb
index bce8312fcb..965f099ed5 100644
--- a/recipes/freesmartphone/libframeworkd-glib_git.bb
+++ b/recipes/freesmartphone/libframeworkd-glib_git.bb
@@ -2,7 +2,8 @@ DESCRIPTION = "freesmartphone.org API glib wrapper"
LICENSE = "LGPL"
SECTION = "devel"
DEPENDS = "dbus-glib"
-PV = "0.0.1+gitr${SRCREV}"
+PV = "0.0.1+gitr${SRCPV}"
+PE = "1"
PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/libframeworkd-glib.git;protocol=git;branch=master"
diff --git a/recipes/freesmartphone/libfso-glib_git.bb b/recipes/freesmartphone/libfso-glib_git.bb
index f7e49cb89d..d9e4372686 100644
--- a/recipes/freesmartphone/libfso-glib_git.bb
+++ b/recipes/freesmartphone/libfso-glib_git.bb
@@ -3,7 +3,8 @@ AUTHOR = "Didier 'Ptitjes"
LICENSE = "LGPL"
SECTION = "devel"
DEPENDS = "vala-native vala-dbus-binding-tool-native dbus-glib glib-2.0 fso-specs"
-PV = "0.2.2+gitr${SRCREV}"
+PV = "0.2.2+gitr${SRCPV}"
+PE = "1"
PR = "r0"
inherit autotools_stage pkgconfig vala
diff --git a/recipes/freesmartphone/libfsobasics_git.bb b/recipes/freesmartphone/libfsobasics_git.bb
index 3a268105d7..ef83a5d041 100644
--- a/recipes/freesmartphone/libfsobasics_git.bb
+++ b/recipes/freesmartphone/libfsobasics_git.bb
@@ -1,5 +1,6 @@
require cornucopia.inc
DESCRIPTION = "freesmartphone.org support library"
-PV = "0.8.2.0+gitr${SRCREV}"
+PV = "0.8.2.0+gitr${SRCPV}"
+PE = "1"
PR = "${INC_PR}.0"
diff --git a/recipes/freesmartphone/libfsoframework_git.bb b/recipes/freesmartphone/libfsoframework_git.bb
index 5840cdbfbc..c78e924118 100644
--- a/recipes/freesmartphone/libfsoframework_git.bb
+++ b/recipes/freesmartphone/libfsoframework_git.bb
@@ -1,6 +1,7 @@
require cornucopia.inc
DESCRIPTION = "freesmartphone.org support library"
DEPENDS += "libfsobasics alsa-lib"
-PV = "0.2.0.0+gitr${SRCREV}"
+PV = "0.2.0.0+gitr${SRCPV}"
+PE = "1"
PR = "${INC_PR}.1"
diff --git a/recipes/freesmartphone/libfsoresource_git.bb b/recipes/freesmartphone/libfsoresource_git.bb
index 40b536f293..8374decfc8 100644
--- a/recipes/freesmartphone/libfsoresource_git.bb
+++ b/recipes/freesmartphone/libfsoresource_git.bb
@@ -1,5 +1,6 @@
require cornucopia.inc
DESCRIPTION = "freesmartphone.org dbus resource library"
DEPENDS += "libfso-glib"
-PV = "0.1.0+gitr${SRCREV}"
+PV = "0.1.0+gitr${SRCPV}"
+PE = "1"
PR = "${INC_PR}.0"
diff --git a/recipes/freesmartphone/libfsotransport_git.bb b/recipes/freesmartphone/libfsotransport_git.bb
index a87fe6cf49..29f3e60ffb 100644
--- a/recipes/freesmartphone/libfsotransport_git.bb
+++ b/recipes/freesmartphone/libfsotransport_git.bb
@@ -1,4 +1,5 @@
require cornucopia.inc
DESCRIPTION = "freesmartphone.org transport library"
-PV = "0.9.4+gitr${SRCREV}"
+PV = "0.9.4+gitr${SRCPV}"
+PE = "1"
PR = "${INC_PR}.0"
diff --git a/recipes/freesmartphone/libgsm0710_git.bb b/recipes/freesmartphone/libgsm0710_git.bb
index 78050c40f5..c748c7aaf0 100644
--- a/recipes/freesmartphone/libgsm0710_git.bb
+++ b/recipes/freesmartphone/libgsm0710_git.bb
@@ -1,7 +1,8 @@
DESCRIPTION = "A GSM 07.10 Protocol Engine"
LICENSE = "GPL"
SECTION = "devel"
-PV = "1.2.0+gitr${SRCREV}"
+PV = "1.2.0+gitr${SRCPV}"
+PE = "1"
PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/libgsm0710.git;protocol=git;branch=master"
diff --git a/recipes/freesmartphone/libgsm0710mux_git.bb b/recipes/freesmartphone/libgsm0710mux_git.bb
index 69446879c3..40adaaa836 100644
--- a/recipes/freesmartphone/libgsm0710mux_git.bb
+++ b/recipes/freesmartphone/libgsm0710mux_git.bb
@@ -3,7 +3,8 @@ AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
LICENSE = "GPL"
SECTION = "devel"
DEPENDS = "glib-2.0 libgsm0710 libfsotransport"
-PV = "0.9.0+gitr${SRCREV}"
+PV = "0.9.0+gitr${SRCPV}"
+PE = "1"
PR = "r0"
SRC_URI = "\
diff --git a/recipes/freesmartphone/libpersistence_git.bb b/recipes/freesmartphone/libpersistence_git.bb
index 8f6aafd42a..ab46850854 100644
--- a/recipes/freesmartphone/libpersistence_git.bb
+++ b/recipes/freesmartphone/libpersistence_git.bb
@@ -3,7 +3,8 @@ AUTHOR = "Jürg Billeter, Michael 'Mickey' Lauer"
LICENSE = "LGPL"
SECTION = "devel"
DEPENDS = "libgee"
-PV = "0.1.0+gitr${SRCREV}"
+PV = "0.1.0+gitr${SRCPV}"
+PE = "1"
PR = "r0"
SRC_URI = "\
diff --git a/recipes/freesmartphone/mickeydbus_git.bb b/recipes/freesmartphone/mickeydbus_git.bb
index 229ff7f1fd..ad2d356944 100644
--- a/recipes/freesmartphone/mickeydbus_git.bb
+++ b/recipes/freesmartphone/mickeydbus_git.bb
@@ -3,7 +3,8 @@ AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "console/network"
LICENSE = "GPLv2"
-PV = "0.9.2+gitr${SRCREV}"
+PV = "0.9.2+gitr${SRCPV}"
+PE = "1"
PR = "r2"
SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
diff --git a/recipes/freesmartphone/mickeyterm_git.bb b/recipes/freesmartphone/mickeyterm_git.bb
index 276eeb55ab..a66290b00e 100644
--- a/recipes/freesmartphone/mickeyterm_git.bb
+++ b/recipes/freesmartphone/mickeyterm_git.bb
@@ -3,7 +3,8 @@ AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "console/network"
LICENSE = "GPLv2"
-PV = "2.9.1+gitr${SRCREV}"
+PV = "2.9.1+gitr${SRCPV}"
+PE = "1"
PR = "r3"
SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
diff --git a/recipes/freesmartphone/multicat_git.bb b/recipes/freesmartphone/multicat_git.bb
index c9344390ed..d31c38668b 100644
--- a/recipes/freesmartphone/multicat_git.bb
+++ b/recipes/freesmartphone/multicat_git.bb
@@ -3,7 +3,8 @@ AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "console"
LICENSE = "GPLv2"
-PV = "0.0.0+gitr${SRCREV}"
+PV = "0.0.0+gitr${SRCPV}"
+PE = "1"
PR = "r1"
SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
diff --git a/recipes/freesmartphone/opimd-utils_git.bb b/recipes/freesmartphone/opimd-utils_git.bb
index 5031ae5c13..726bfa865d 100644
--- a/recipes/freesmartphone/opimd-utils_git.bb
+++ b/recipes/freesmartphone/opimd-utils_git.bb
@@ -1,27 +1,48 @@
DESCRIPTION = "Test scripts for freesmartphone.org opimd interface"
HOMEPAGE = "http://freesmartphone.org"
+SHR_RELEASE ?= "shr"
LICENSE ?= "GPL"
+RDEPENDS = "python-elementary python-dbus python-codecs python-shell python python-core python-edbus frameworkd"
SECTION = "x11/application"
-PV = "0.0.2+gitr${SRCREV}"
+PV = "0.0.3+gitr${SRCPV}"
PR = "r0"
+PE = "1"
inherit setuptools
-SRC_URI = "git://git.shr-project.org/repo/opimd-utils.git;protocol=http"
-S = "${WORKDIR}/git"
+PACKAGES =+ "\
+ ${PN}-cli \
+ ${PN}-notes \
+ ${PN}-data \
+"
-RDEPENDS = "\
- python-elementary \
- python-edbus \
- python-codecs \
- python-shell \
- \
+RDEPENDS_${PN} = "\
+ ${PN}-data \
shr-settings \
- shr-theme \
- frameworkd \
pyphonelog \
+ shr-theme \
+"
+
+RDEPENDS_${PN}-notes = "\
+ ${PN}-data \
+"
+
+RRECOMMENDS_${PN} = "\
+ ${PN}-notes \
+ ${PN}-cli \
"
+PACKAGE_ARCH_${PN}-cli = "all"
+PACKAGE_ARCH_${PN}-data = "all"
+PACKAGE_ARCH_${PN}-notes = "all"
+
+SRC_URI = "git://git.shr-project.org/repo/opimd-utils.git;protocol=http"
+S = "${WORKDIR}/git"
FILES_${PN} += "${sysconfdir}/X11/Xsession.d/89opimd-notifier"
FILES_${PN} += "${prefix}/share/applications/"
-FILES_${PN} += "${prefix}/share/pixmaps/opimd-utils/"
+FILES_${PN} += "${prefix}/share/pixmaps/"
+FILES_${PN}-data += "${prefix}/share/pixmaps/opimd-utils/"
+FILES_${PN}-cli += "${prefix}/bin/opimd-cli"
+FILES_${PN}-notes += "${prefix}/bin/opimd-notes"
+FILES_${PN}-notes += "${prefix}/share/pixmaps/opimd-notes.png"
+FILES_${PN}-notes += "${prefix}/share/applications/opimd-notes.desktop"
diff --git a/recipes/freesmartphone/pycd_git.bb b/recipes/freesmartphone/pycd_git.bb
index 3ed2b75292..449cc2268d 100644
--- a/recipes/freesmartphone/pycd_git.bb
+++ b/recipes/freesmartphone/pycd_git.bb
@@ -3,7 +3,8 @@ AUTHOR = "Jan Luebbe <jluebbe@debian.org>"
HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "console/network"
LICENSE = "GPLv2"
-PV = "0.1+gitr${SRCREV}"
+PV = "0.1+gitr${SRCPV}"
+PE = "1"
PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
diff --git a/recipes/freesmartphone/vala-dbus-binding-tool-native_git.bb b/recipes/freesmartphone/vala-dbus-binding-tool-native_git.bb
index ebae18b628..145672ffe7 100644
--- a/recipes/freesmartphone/vala-dbus-binding-tool-native_git.bb
+++ b/recipes/freesmartphone/vala-dbus-binding-tool-native_git.bb
@@ -2,7 +2,8 @@ DESCRIPTION = "Vala DBus Binding Tool"
SECTION = "console"
LICENSE = "GPLv2"
DEPENDS = "vala-native libgee-native intltool-native libxml2-native"
-PV = "0.1.0+gitr${SRCREV}"
+PV = "0.1.0+gitr${SRCPV}"
+PE = "1"
SRC_URI = "${FREESMARTPHONE_GIT}/vala-dbus-binding-tool.git;protocol=git;branch=master"
S = "${WORKDIR}/git"
diff --git a/recipes/freesmartphone/zhone_git.bb b/recipes/freesmartphone/zhone_git.bb
index 0fcc25c5f6..dba47be911 100644
--- a/recipes/freesmartphone/zhone_git.bb
+++ b/recipes/freesmartphone/zhone_git.bb
@@ -2,7 +2,8 @@ DESCRIPTION = "A phone UI based on the freesmartphone.org framework"
LICENSE = "GPL"
SECTION = "x11"
DEPENDS = "edje-native python-pyrex-native python-cython-native"
-PV = "0.0.2+gitr${SRCREV}"
+PV = "0.0.2+gitr${SRCPV}"
+PE = "1"
PR = "r12"
SRC_URI = "${FREESMARTPHONE_GIT}/zhone.git;protocol=git;branch=master \