aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/zhone_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone/zhone_git.bb')
-rw-r--r--recipes/freesmartphone/zhone_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/freesmartphone/zhone_git.bb b/recipes/freesmartphone/zhone_git.bb
new file mode 100644
index 0000000000..0fcc25c5f6
--- /dev/null
+++ b/recipes/freesmartphone/zhone_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A phone UI based on the freesmartphone.org framework"
+LICENSE = "GPL"
+SECTION = "x11"
+DEPENDS = "edje-native python-pyrex-native python-cython-native"
+PV = "0.0.2+gitr${SRCREV}"
+PR = "r12"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/zhone.git;protocol=git;branch=master \
+ file://80zhone"
+S = "${WORKDIR}/git"
+
+inherit distutils
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/X11/Xsession.d/
+ install -m 0755 ${WORKDIR}/80zhone ${D}${sysconfdir}/X11/Xsession.d/
+}
+
+FILES_${PN} += "${datadir} ${sysconfdir}"
+
+RDEPENDS = "\
+ task-python-efl \
+ python-logging \
+ python-textutils \
+ python-dbus \
+ python-pycairo \
+"