aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/fsod/autofoo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone/fsod/autofoo.patch')
-rw-r--r--recipes/freesmartphone/fsod/autofoo.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes/freesmartphone/fsod/autofoo.patch b/recipes/freesmartphone/fsod/autofoo.patch
new file mode 100644
index 0000000000..3ed26aeb79
--- /dev/null
+++ b/recipes/freesmartphone/fsod/autofoo.patch
@@ -0,0 +1,13 @@
+Index: fsod/configure.ac
+===================================================================
+--- fsod/configure.ac
++++ ~fsod/configure.ac
+@@ -85,7 +85,7 @@ if test "x$have_python" != "xno"; then
+ PY_EXEC_PREFIX=`$PYTHON -c 'import sys ; print sys.exec_prefix'`
+ PYTHON_LIBS="-lpython$PYTHON_VERSION"
+ PYTHON_LIB_LOC="-L$PY_EXEC_PREFIX/lib/python$PYTHON_VERSION/config"
+- PYTHON_CFLAGS="-I$PY_PREFIX/include/python$PYTHON_VERSION"
++ PYTHON_CFLAGS="${PYTHON_INCLUDES}" # "-I`$PYTHON -c 'from distutils import sysconfig; print sysconfig.get_python_inc()'`"
+ PYTHON_MAKEFILE="$PY_EXEC_PREFIX/lib/python$PYTHON_VERSION/config/Makefile"
+ PYTHON_LOCALMODLIBS=`sed -n -e 's/^LOCALMODLIBS=\(.*\)/\1/p' $PYTHON_MAKEFILE`
+ PYTHON_BASEMODLIBS=`sed -n -e 's/^BASEMODLIBS=\(.*\)/\1/p' $PYTHON_MAKEFILE`