aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dvsdk/ti-cgt6x-native_6.1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dvsdk/ti-cgt6x-native_6.1.9.bb')
-rw-r--r--recipes/dvsdk/ti-cgt6x-native_6.1.9.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/dvsdk/ti-cgt6x-native_6.1.9.bb b/recipes/dvsdk/ti-cgt6x-native_6.1.9.bb
new file mode 100644
index 0000000000..55c1b6ca06
--- /dev/null
+++ b/recipes/dvsdk/ti-cgt6x-native_6.1.9.bb
@@ -0,0 +1,22 @@
+require ti-cgt6x.inc
+inherit native
+
+# download ti_cgt_c6000_6.1.9_setup_linux_x86.bin from https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm and copy in Arago (or OE) download directory.
+
+SRC_URI = "http://install.source.dir.com/ti_cgt_c6000_6.1.9_setup_linux_x86.bin"
+
+BINFILE = "ti_cgt_c6000_6.1.9_setup_linux_x86.bin"
+
+S = "${WORKDIR}/cgt"
+
+# Yes, the xdc stuff still breaks with a '.' in PWD
+PV = "6190"
+PR = "r1"
+
+do_stage() {
+ install -d ${STAGING_DIR_NATIVE}/${PN}
+ cp -pPrf ${S}/* ${STAGING_DIR_NATIVE}/${PN}/
+}
+
+AUTOTOOLS_NATIVE_STAGE_INSTALL = "1"
+