summaryrefslogtreecommitdiffstats
path: root/recipes/coreutils/coreutils-6.0
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/coreutils/coreutils-6.0')
-rw-r--r--recipes/coreutils/coreutils-6.0/coreutils-install-use-STRIP.patch29
-rw-r--r--recipes/coreutils/coreutils-6.0/futimens.patch57
-rw-r--r--recipes/coreutils/coreutils-6.0/man.patch42
-rw-r--r--recipes/coreutils/coreutils-6.0/oe-old-tools.patch26
-rw-r--r--recipes/coreutils/coreutils-6.0/onceonly.m463
-rw-r--r--recipes/coreutils/coreutils-6.0/uptime-pow-lib.patch11
6 files changed, 0 insertions, 228 deletions
diff --git a/recipes/coreutils/coreutils-6.0/coreutils-install-use-STRIP.patch b/recipes/coreutils/coreutils-6.0/coreutils-install-use-STRIP.patch
deleted file mode 100644
index 1af9fb97b6..0000000000
--- a/recipes/coreutils/coreutils-6.0/coreutils-install-use-STRIP.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Index: coreutils-6.0/src/install.c
-===================================================================
---- coreutils-6.0.orig/src/install.c 2009-03-04 15:37:45.000000000 -0800
-+++ coreutils-6.0/src/install.c 2009-03-04 15:38:57.000000000 -0800
-@@ -526,7 +526,14 @@
- strip (char const *name)
- {
- int status;
-- pid_t pid = fork ();
-+ pid_t pid;
-+ char *strip_name;
-+
-+ strip_name = getenv ("STRIP");
-+ if (strip_name == NULL)
-+ strip_name = "strip";
-+
-+ pid = fork ();
-
- switch (pid)
- {
-@@ -534,7 +541,7 @@
- error (EXIT_FAILURE, errno, _("fork system call failed"));
- break;
- case 0: /* Child. */
-- execlp ("strip", "strip", name, NULL);
-+ execlp (strip_name, "strip", name, NULL);
- error (EXIT_FAILURE, errno, _("cannot run strip"));
- break;
- default: /* Parent. */
diff --git a/recipes/coreutils/coreutils-6.0/futimens.patch b/recipes/coreutils/coreutils-6.0/futimens.patch
deleted file mode 100644
index b3089b1c05..0000000000
--- a/recipes/coreutils/coreutils-6.0/futimens.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-Index: coreutils-6.0/lib/utimens.c
-===================================================================
---- coreutils-6.0.orig/lib/utimens.c 2006-06-11 09:14:31.000000000 +0200
-+++ coreutils-6.0/lib/utimens.c 2008-12-04 13:36:46.000000000 +0100
-@@ -75,8 +75,8 @@
- Return 0 on success, -1 (setting errno) on failure. */
-
- int
--futimens (int fd ATTRIBUTE_UNUSED,
-- char const *file, struct timespec const timespec[2])
-+gl_futimens (int fd ATTRIBUTE_UNUSED,
-+ char const *file, struct timespec const timespec[2])
- {
- /* There's currently no interface to set file timestamps with
- nanosecond resolution, so do the best we can, discarding any
-@@ -168,5 +168,5 @@
- int
- utimens (char const *file, struct timespec const timespec[2])
- {
-- return futimens (-1, file, timespec);
-+ return gl_futimens (-1, file, timespec);
- }
-Index: coreutils-6.0/lib/utimens.h
-===================================================================
---- coreutils-6.0.orig/lib/utimens.h 2004-11-23 21:41:51.000000000 +0100
-+++ coreutils-6.0/lib/utimens.h 2008-12-04 13:36:46.000000000 +0100
-@@ -1,3 +1,3 @@
- #include "timespec.h"
--int futimens (int, char const *, struct timespec const [2]);
-+int gl_futimens (int, char const *, struct timespec const [2]);
- int utimens (char const *, struct timespec const [2]);
-Index: coreutils-6.0/src/touch.c
-===================================================================
---- coreutils-6.0.orig/src/touch.c 2005-11-02 11:01:07.000000000 +0100
-+++ coreutils-6.0/src/touch.c 2008-12-04 13:37:43.000000000 +0100
-@@ -182,7 +182,7 @@
- t = timespec;
- }
-
-- ok = (futimens (fd, (fd == STDOUT_FILENO ? NULL : file), t) == 0);
-+ ok = (gl_futimens (fd, (fd == STDOUT_FILENO ? NULL : file), t) == 0);
-
- if (fd == STDIN_FILENO)
- {
-Index: coreutils-6.0/src/copy.c
-===================================================================
---- coreutils-6.0.orig/src/copy.c 2008-12-04 13:38:56.000000000 +0100
-+++ coreutils-6.0/src/copy.c 2008-12-04 13:39:01.000000000 +0100
-@@ -490,7 +490,7 @@
- timespec[0] = get_stat_atime (src_sb);
- timespec[1] = get_stat_mtime (src_sb);
-
-- if (futimens (dest_desc, dst_name, timespec) != 0)
-+ if (gl_futimens (dest_desc, dst_name, timespec) != 0)
- {
- error (0, errno, _("preserving times for %s"), quote (dst_name));
- if (x->require_preserve)
diff --git a/recipes/coreutils/coreutils-6.0/man.patch b/recipes/coreutils/coreutils-6.0/man.patch
deleted file mode 100644
index 5060e4fdff..0000000000
--- a/recipes/coreutils/coreutils-6.0/man.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- coreutils-5.3.0/configure.ac~man
-+++ coreutils-5.3.0/configure.ac
-@@ -237,6 +237,20 @@
- AM_GNU_GETTEXT([external], [need-ngettext])
- AM_GNU_GETTEXT_VERSION(0.13.1)
-
-+AC_MSG_CHECKING([whether to build man pages])
-+AC_ARG_WITH(manpages,
-+ AS_HELP_STRING([--with-manpages],
-+ [Enable building of manpages (default=yes)]),
-+ [cu_cv_build_manpages=$enableval],
-+ [cu_cv_build_manpages=yes])
-+# help2man doesn't work when crosscompiling, as it needs to run the
-+# binary that was built.
-+if test x"$cross_compiling" = x"yes"; then
-+ cu_cv_build_manpages=no
-+fi
-+AC_MSG_RESULT($cu_cv_build_manpages)
-+AM_CONDITIONAL(ENABLE_MANPAGES, test x"$cu_cv_build_manpages" = x"yes")
-+
- AC_CONFIG_FILES(
- Makefile
- doc/Makefile
---- coreutils-5.3.0/Makefile.am~man
-+++ coreutils-5.3.0/Makefile.am
-@@ -1,6 +1,11 @@
- ## Process this file with automake to produce Makefile.in -*-Makefile-*-
-
-+if ENABLE_MANPAGES
- SUBDIRS = lib src doc man po tests
-+else
-+SUBDIRS = lib src doc po tests
-+endif
-+
- EXTRA_DIST = Makefile.cfg Makefile.maint GNUmakefile \
- .kludge-stamp .prev-version THANKS-to-translators THANKStt.in \
- .x-sc_space_tab .x-sc_sun_os_names \
diff --git a/recipes/coreutils/coreutils-6.0/oe-old-tools.patch b/recipes/coreutils/coreutils-6.0/oe-old-tools.patch
deleted file mode 100644
index 495da36cf7..0000000000
--- a/recipes/coreutils/coreutils-6.0/oe-old-tools.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: coreutils-6.0/configure.ac
-===================================================================
---- coreutils-6.0.orig/configure.ac 2007-04-02 11:21:27.000000000 +0200
-+++ coreutils-6.0/configure.ac 2007-04-02 11:21:36.000000000 +0200
-@@ -26,7 +26,7 @@
- AC_CONFIG_HEADERS([config.h:config.hin])
-
- AB_INIT()
--AM_INIT_AUTOMAKE([1.9.6 gnits dist-bzip2])
-+AM_INIT_AUTOMAKE([1.9.3 gnits dist-bzip2])
-
- gl_DEFAULT_POSIX2_VERSION
- gl_USE_SYSTEM_EXTENSIONS
-Index: coreutils-6.0/m4/jm-macros.m4
-===================================================================
---- coreutils-6.0.orig/m4/jm-macros.m4 2007-04-02 11:21:54.000000000 +0200
-+++ coreutils-6.0/m4/jm-macros.m4 2007-04-02 11:22:02.000000000 +0200
-@@ -23,7 +23,7 @@
-
- AC_DEFUN([gl_MACROS],
- [
-- AC_PREREQ(2.60)
-+ AC_PREREQ(2.59)
-
- GNU_PACKAGE="GNU $PACKAGE"
- AC_DEFINE_UNQUOTED(GNU_PACKAGE, "$GNU_PACKAGE",
diff --git a/recipes/coreutils/coreutils-6.0/onceonly.m4 b/recipes/coreutils/coreutils-6.0/onceonly.m4
deleted file mode 100644
index f6fec37cbf..0000000000
--- a/recipes/coreutils/coreutils-6.0/onceonly.m4
+++ /dev/null
@@ -1,63 +0,0 @@
-# onceonly.m4 serial 3
-dnl Copyright (C) 2002, 2003 Free Software Foundation, Inc.
-dnl This file is free software, distributed under the terms of the GNU
-dnl General Public License. As a special exception to the GNU General
-dnl Public License, this file may be distributed as part of a program
-dnl that contains a configuration script generated by Autoconf, under
-dnl the same distribution terms as the rest of that program.
-
-dnl This file defines some "once only" variants of standard autoconf macros.
-dnl AC_CHECK_HEADERS_ONCE like AC_CHECK_HEADERS
-dnl AC_CHECK_FUNCS_ONCE like AC_CHECK_FUNCS
-dnl AC_CHECK_DECLS_ONCE like AC_CHECK_DECLS
-dnl AC_REQUIRE([AC_HEADER_STDC]) like AC_HEADER_STDC
-dnl The advantage is that the check for each of the headers/functions/decls
-dnl will be put only once into the 'configure' file. It keeps the size of
-dnl the 'configure' file down, and avoids redundant output when 'configure'
-dnl is run.
-dnl The drawback is that the checks cannot be conditionalized. If you write
-dnl if some_condition; then gl_CHECK_HEADERS(stdlib.h); fi
-dnl inside an AC_DEFUNed function, the gl_CHECK_HEADERS macro call expands to
-dnl empty, and the check will be inserted before the body of the AC_DEFUNed
-dnl function.
-
-dnl Autoconf version 2.57 or newer is recommended.
-AC_PREREQ(2.54)
-
-# AC_CHECK_HEADERS_ONCE(HEADER1 HEADER2 ...) is a once-only variant of
-# AC_CHECK_HEADERS(HEADER1 HEADER2 ...).
-AC_DEFUN([AC_CHECK_HEADERS_ONCE], [
- :
- AC_FOREACH([gl_HEADER_NAME], [$1], [
- AC_DEFUN([gl_CHECK_HEADER_]m4_quote(translit(defn([gl_HEADER_NAME]),
- [-./], [___])), [
- AC_CHECK_HEADERS(gl_HEADER_NAME)
- ])
- AC_REQUIRE([gl_CHECK_HEADER_]m4_quote(translit(gl_HEADER_NAME,
- [-./], [___])))
- ])
-])
-
-# AC_CHECK_FUNCS_ONCE(FUNC1 FUNC2 ...) is a once-only variant of
-# AC_CHECK_FUNCS(FUNC1 FUNC2 ...).
-AC_DEFUN([AC_CHECK_FUNCS_ONCE], [
- :
- AC_FOREACH([gl_FUNC_NAME], [$1], [
- AC_DEFUN([gl_CHECK_FUNC_]defn([gl_FUNC_NAME]), [
- AC_CHECK_FUNCS(defn([gl_FUNC_NAME]))
- ])
- AC_REQUIRE([gl_CHECK_FUNC_]defn([gl_FUNC_NAME]))
- ])
-])
-
-# AC_CHECK_DECLS_ONCE(DECL1 DECL2 ...) is a once-only variant of
-# AC_CHECK_DECLS(DECL1, DECL2, ...).
-AC_DEFUN([AC_CHECK_DECLS_ONCE], [
- :
- AC_FOREACH([gl_DECL_NAME], [$1], [
- AC_DEFUN([gl_CHECK_DECL_]defn([gl_DECL_NAME]), [
- AC_CHECK_DECLS(defn([gl_DECL_NAME]))
- ])
- AC_REQUIRE([gl_CHECK_DECL_]defn([gl_DECL_NAME]))
- ])
-])
diff --git a/recipes/coreutils/coreutils-6.0/uptime-pow-lib.patch b/recipes/coreutils/coreutils-6.0/uptime-pow-lib.patch
deleted file mode 100644
index 5eb3fca676..0000000000
--- a/recipes/coreutils/coreutils-6.0/uptime-pow-lib.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- coreutils-5.3.0/src/Makefile.am.orig 2005-09-27 22:34:35.659272058 -0700
-+++ coreutils-5.3.0/src/Makefile.am 2005-09-27 22:34:39.403507668 -0700
-@@ -74,7 +74,7 @@
- sleep_LDADD = $(nanosec_libs)
- tail_LDADD = $(nanosec_libs)
-
--uptime_LDADD = $(LDADD) $(GETLOADAVG_LIBS)
-+uptime_LDADD = $(LDADD) $(POW_LIB) $(GETLOADAVG_LIBS)
-
- su_LDADD = $(LDADD) $(LIB_CRYPT)
-