aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ccrtp/ccrtp_1.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ccrtp/ccrtp_1.7.0.bb')
-rw-r--r--recipes/ccrtp/ccrtp_1.7.0.bb16
1 files changed, 10 insertions, 6 deletions
diff --git a/recipes/ccrtp/ccrtp_1.7.0.bb b/recipes/ccrtp/ccrtp_1.7.0.bb
index 1ebfddb7c2..c61dd7357e 100644
--- a/recipes/ccrtp/ccrtp_1.7.0.bb
+++ b/recipes/ccrtp/ccrtp_1.7.0.bb
@@ -1,12 +1,16 @@
DESCRIPTION = "GNU Common C++"
HOMEPAGE = "http://freshmeat.net/projects/ccrtp"
LICENSE = "GPL"
-PR="r0"
DEPENDS = "commoncpp2"
-SRC_URI = "ftp://ftp.gnu.org/gnu/ccrtp/ccrtp-${PV}.tar.gz \
- file://configure.ac.patch;patch=1"
+PR = "r0"
-inherit autotools pkgconfig autotools_stage
+SRC_URI = "ftp://ftp.gnu.org/gnu/ccrtp/ccrtp-${PV}.tar.gz;name=archive \
+ file://configure.ac.patch"
+SRC_URI[archive.md5sum] = "eb86cd2ac06af27ea60b1a349122605c"
+SRC_URI[archive.sha256sum] = "923cd26ffc43903ef33704e46fd57f659c3ad01554927fe323635a73082d56ae"
-SRC_URI[md5sum] = "eb86cd2ac06af27ea60b1a349122605c"
-SRC_URI[sha256sum] = "923cd26ffc43903ef33704e46fd57f659c3ad01554927fe323635a73082d56ae"
+inherit pkgconfig autotools_stage
+
+do_configure_prepend () {
+ sed -i -e 's#COMMON_LIBPATH=`pkg-config --variable=libdir libccgnu2`#COMMON_LIBPATH=${STAGING_LIBDIR}#' configure.ac
+}