aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/buglabs
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/buglabs')
-rw-r--r--recipes/buglabs/repo-feed-configs.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/buglabs/repo-feed-configs.bb b/recipes/buglabs/repo-feed-configs.bb
new file mode 100644
index 0000000000..d2060f70e0
--- /dev/null
+++ b/recipes/buglabs/repo-feed-configs.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Configuration files for public online package repositories aka feeds."
+HOMEPAGE="http://repo.buglabs.net/"
+PR = "r1"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+FEED_BASEPATH = "2.0/"
+
+do_compile() {
+ mkdir -p ${S}/${sysconfdir}/opkg
+
+ for feed in all armv7a bug20 ; do
+ echo "src/gz repo-${feed} http://repo.buglabs.net/${FEED_BASEPATH}${feed}" > ${S}/${sysconfdir}/opkg/repo-${feed}-feed.conf
+ done
+}
+
+
+do_install () {
+ install -d ${D}${sysconfdir}/opkg
+ install -m 0644 ${S}/${sysconfdir}/opkg/* ${D}${sysconfdir}/opkg/
+}
+
+FILES_${PN} = "${sysconfdir}/opkg/"
+
+CONFFILES_${PN} += "${sysconfdir}/opkg/*.conf"