summaryrefslogtreecommitdiffstats
path: root/recipes/bitbake
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/bitbake')
-rw-r--r--recipes/bitbake/bitbake.inc22
-rw-r--r--recipes/bitbake/bitbake_1.8.12.bb5
-rw-r--r--recipes/bitbake/bitbake_svn.bb10
3 files changed, 37 insertions, 0 deletions
diff --git a/recipes/bitbake/bitbake.inc b/recipes/bitbake/bitbake.inc
new file mode 100644
index 0000000000..4669006979
--- /dev/null
+++ b/recipes/bitbake/bitbake.inc
@@ -0,0 +1,22 @@
+DESCRIPTION = "BitBake is a simple tool for the execution of tasks. It is \
+derived from Portage, which is the package management system used by the \
+Gentoo Linux distribution. It is most commonly used to build packages, as it \
+can easily use its rudimentary inheritence to abstract common operations, such \
+as fetching sources, unpacking them, patching them, compiling them, and so on. \
+It is the basis of the OpenEmbedded project, which is being used for \
+Angstrom and a number of other embedded Linux distributions."
+HOMEPAGE = "http://developer.berlios.de/projects/bitbake/"
+LICENSE = "GPL MIT"
+SECTION = "devel"
+SUMMARY = "BitBake build tool"
+RDEPENDS += "python-shell python-lang python-textutils python-pickle python-crypt python-netclient"
+
+# crypt for md5
+# netclient for tinderclient.bbclass
+
+# We don't need a toolchain...
+INHIBIT_DEFAULT_DEPS = "1"
+
+inherit distutils
+
+FILES_${PN} += "${datadir}/bitbake"
diff --git a/recipes/bitbake/bitbake_1.8.12.bb b/recipes/bitbake/bitbake_1.8.12.bb
new file mode 100644
index 0000000000..ed74704d2f
--- /dev/null
+++ b/recipes/bitbake/bitbake_1.8.12.bb
@@ -0,0 +1,5 @@
+require bitbake.inc
+PR = "r0"
+
+SRC_URI = "http://download.berlios.de/bitbake/bitbake-${PV}.tar.gz"
+S = "${WORKDIR}/bitbake-${PV}"
diff --git a/recipes/bitbake/bitbake_svn.bb b/recipes/bitbake/bitbake_svn.bb
new file mode 100644
index 0000000000..ab85dc85ab
--- /dev/null
+++ b/recipes/bitbake/bitbake_svn.bb
@@ -0,0 +1,10 @@
+require bitbake.inc
+
+PV = "1.9.0+svn${SRCDATE}"
+PR = "r1"
+
+# Don't use the tip of svn by default
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "svn://svn.berlios.de/bitbake/trunk;module=bitbake"
+S = "${WORKDIR}/bitbake"