aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/aceofpenguins/aceofpenguins_1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/aceofpenguins/aceofpenguins_1.2.bb')
-rw-r--r--recipes/aceofpenguins/aceofpenguins_1.2.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/recipes/aceofpenguins/aceofpenguins_1.2.bb b/recipes/aceofpenguins/aceofpenguins_1.2.bb
index 9410eb9653..c4b98e4fb0 100644
--- a/recipes/aceofpenguins/aceofpenguins_1.2.bb
+++ b/recipes/aceofpenguins/aceofpenguins_1.2.bb
@@ -3,16 +3,21 @@ The latest version includes clones of freecell, golf, mastermind, merlin, minesw
AUTHOR = "dj@delorie.com"
HOMEPAGE = "http://www.delorie.com/store/ace/"
SECTION = "games"
-DEPENDS = "libpng zlib libxpm"
-PR = "r1"
+DEPENDS = "libpng-native zlib-native libxpm"
+PR = "r2"
SRC_URI = "\
http://www.delorie.com/store/ace/ace-${PV}.tar.gz\
file://gcc4.patch;patch=1\
+ file://fix-crosscompile.patch;patch=1\
"
S = "${WORKDIR}/ace-${PV}"
inherit autotools
+do_compile_prepend() {
+ export LD_LIBRARY_PATH="${STAGING_NATIVE_DIR}"
+}
+
# Workaround QA issue
-TARGET_CC_ARCH += "${LDFLAGS}" \ No newline at end of file
+TARGET_CC_ARCH += "${LDFLAGS}"