aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/apmd/apmd-3.2.2/select-instead-of-sleep.patch107
-rw-r--r--packages/apmd/apmd_3.2.2.bb3
-rw-r--r--packages/base-files/base-files/h2200/.mtn2git_empty (renamed from packages/detect-stylus/detect-stylus-0.13/.mtn2git_empty)0
-rw-r--r--packages/base-files/base-files/h2200/fstab6
-rw-r--r--packages/detect-stylus/detect-tsdevice_0.13.bb20
-rw-r--r--packages/detect-stylus/files/.mtn2git_empty0
-rw-r--r--packages/detect-stylus/files/access.patch (renamed from packages/detect-stylus/access.patch)0
-rw-r--r--packages/detect-stylus/files/correct-theme-name.patch (renamed from packages/detect-stylus/detect-stylus-0.13/correct-theme-name.patch)0
-rw-r--r--packages/detect-stylus/files/extra-device-check.patch (renamed from packages/detect-stylus/detect-stylus-0.13/extra-device-check.patch)0
-rw-r--r--packages/detect-stylus/files/nox.patch86
-rw-r--r--packages/gpe-bluetooth/files/fix-resume-script-name.patch18
-rw-r--r--packages/gpe-bluetooth/gpe-bluetooth_0.51.bb3
-rw-r--r--packages/gpe-plucker/gpe-plucker/gpe-plucker-desktop.patch17
-rw-r--r--packages/gpe-plucker/gpe-plucker_0.2.bb4
-rw-r--r--packages/libsdl/libsdl-mixer_1.2.6.bb4
-rw-r--r--packages/linux/handhelds-pxa-2.6_2.6.15-hh1.bb35
-rw-r--r--packages/linux/handhelds-pxa_2.4.19-rmk6-pxa1-hh41.bb3
-rw-r--r--packages/python/python-pygtk2_2.6.2.bb3
-rw-r--r--packages/python/python_2.4.2.bb8
-rw-r--r--packages/tslib/tslib/h1940/tslib.sh2
-rw-r--r--packages/tslib/tslib/h2200/tslib.sh2
-rw-r--r--packages/tslib/tslib/h3600/tslib.sh2
-rw-r--r--packages/tslib/tslib/h3900/tslib.sh2
-rw-r--r--packages/tslib/tslib/h6300/tslib.sh2
-rw-r--r--packages/tslib/tslib/ipaq-pxa270/tslib.sh2
-rw-r--r--packages/tslib/tslib_cvs.bb16
-rw-r--r--packages/udev/udev-084/local.rules28
-rw-r--r--packages/udev/udev-084/udev.rules2
-rw-r--r--packages/udev/udev_084.bb4
-rw-r--r--packages/xstroke/xstroke_0.6.bb2
-rw-r--r--packages/xstroke/xstroke_cvs.bb13
31 files changed, 359 insertions, 35 deletions
diff --git a/packages/apmd/apmd-3.2.2/select-instead-of-sleep.patch b/packages/apmd/apmd-3.2.2/select-instead-of-sleep.patch
new file mode 100644
index 0000000000..94acfedcdc
--- /dev/null
+++ b/packages/apmd/apmd-3.2.2/select-instead-of-sleep.patch
@@ -0,0 +1,107 @@
+--- apmd/apmd.c~ 2006-04-10 20:10:42.787178752 +0100
++++ apmd/apmd.c 2006-04-17 20:16:25.984067744 +0100
+@@ -345,6 +345,7 @@
+ int status, retval;
+ ssize_t len;
+ time_t countdown;
++ struct timeval timeout;
+
+ if (pid < 0) {
+ /* Couldn't fork */
+@@ -357,56 +358,50 @@
+ /* Capture the child's output, if any, but only until it terminates */
+ close(fds[1]);
+ fcntl(fds[0], F_SETFL, O_RDONLY|O_NONBLOCK);
+- countdown = proxy_timeout;
+- do {
+- countdown -= 1;
+- while ((len = read(fds[0], line, sizeof(line)-1)) > 0) {
+- line[len] = 0;
+- APMD_SYSLOG(LOG_INFO, "+ %s", line);
+- }
+-
+- retval = waitpid(pid, &status, WNOHANG);
+- if (retval == pid)
+- goto proxy_done;
+- if (retval < 0) {
+- APMD_TRACE1(LOG_ERR, "waitpid() failed: %s", strerror(errno));
+- status = __W_EXITCODE(0, SIGTERM) | __WCOREFLAG;
+- goto proxy_done;
+- }
+-
+- while (sleep(1) > 0) ;
+- } while (
+- (countdown >= 0)
+- || (proxy_timeout < 0)
+- );
+-
+- APMD_SYSLOG(LOG_NOTICE, "Proxy has been running more than %d seconds; killing it", proxy_timeout);
+-
+- kill(pid, SIGTERM);
+- countdown = 5;
+- do {
+- retval = waitpid(pid, &status, WNOHANG);
+- if (retval == pid)
+- goto proxy_done;
+- if (retval < 0) {
+- APMD_TRACE1(LOG_ERR, "waitpid() failed: %s", strerror(errno));
+- status = __W_EXITCODE(0, SIGTERM) | __WCOREFLAG;
+- goto proxy_done;
++ timeout.tv_sec = proxy_timeout;
++ timeout.tv_usec = 0;
++ for (;;) {
++ int r;
++ fd_set rfds;
++ FD_ZERO (&rfds);
++ FD_SET (fds[0], &rfds);
++ r = select (fds[0] + 1, &rfds, NULL, NULL, &timeout);
++ if (r == 0) {
++ APMD_SYSLOG(LOG_NOTICE, "Proxy has been running more than %d seconds; killing it", proxy_timeout);
++
++ kill(pid, SIGTERM);
++ countdown = 5;
++ do {
++ retval = waitpid(pid, &status, WNOHANG);
++ if (retval == pid)
++ goto proxy_done;
++ if (retval < 0) {
++ APMD_TRACE1(LOG_ERR, "waitpid() failed: %s", strerror(errno));
++ status = __W_EXITCODE(0, SIGTERM) | __WCOREFLAG;
++ goto proxy_done;
++ }
++ while (sleep(1) > 0) ;
++ } while (countdown-- >= 0);
++
++ kill(pid, SIGKILL);
++
++ break;
++ } else if (r < 0) {
++ perror ("select");
++ break;
++ } else {
++ len = read(fds[0], line, sizeof(line)-1);
++ if (len > 0) {
++ line[len] = 0;
++ APMD_SYSLOG(LOG_INFO, "+ %s", line);
++ } else
++ break;
+ }
++ }
+
+- while (sleep(1) > 0) ;
+-
+- } while (countdown >= 0);
+-
+- kill(pid, SIGKILL);
+- status = __W_EXITCODE(0, SIGKILL);
++ retval = waitpid(pid, &status, 0);
+
+ proxy_done:
+- /* Flush any remaining data */
+- while ((len = read(fds[0], line, sizeof(line)-1)) > 0) {
+- line[len] = 0;
+- APMD_SYSLOG(LOG_INFO, "+ %s", line);
+- }
+ close(fds[0]);
+
+ /* Collect the exit code */
diff --git a/packages/apmd/apmd_3.2.2.bb b/packages/apmd/apmd_3.2.2.bb
index 07bad03f7f..e335e20839 100644
--- a/packages/apmd/apmd_3.2.2.bb
+++ b/packages/apmd/apmd_3.2.2.bb
@@ -3,11 +3,12 @@ SECTION = "base"
PRIORITY = "required"
DEPENDS = "libtool-cross"
LICENSE = "GPL"
-PR = "r8"
+PR = "r9"
SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_${PV}.orig.tar.gz; \
file://debian.patch;patch=1 \
file://workaround.patch;patch=1 \
+ file://select-instead-of-sleep.patch;patch=1 \
file://init \
file://default \
file://apmd_proxy \
diff --git a/packages/detect-stylus/detect-stylus-0.13/.mtn2git_empty b/packages/base-files/base-files/h2200/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/detect-stylus/detect-stylus-0.13/.mtn2git_empty
+++ b/packages/base-files/base-files/h2200/.mtn2git_empty
diff --git a/packages/base-files/base-files/h2200/fstab b/packages/base-files/base-files/h2200/fstab
new file mode 100644
index 0000000000..397da6c123
--- /dev/null
+++ b/packages/base-files/base-files/h2200/fstab
@@ -0,0 +1,6 @@
+/dev/mtdblock3 / jffs2 defaults 1 1
+proc /proc proc defaults 0 0
+sys /sys sysfs defaults 0 0
+tmpfs /var tmpfs defaults 0 0
+/dev/hda1 /media/cf auto defaults,sync,noauto,noatime,exec,suid 0 0
+/dev/mmcblk0p1 /media/card auto defaults,sync,noauto,noatime,exec,suid 0 0
diff --git a/packages/detect-stylus/detect-tsdevice_0.13.bb b/packages/detect-stylus/detect-tsdevice_0.13.bb
new file mode 100644
index 0000000000..a42a14c88b
--- /dev/null
+++ b/packages/detect-stylus/detect-tsdevice_0.13.bb
@@ -0,0 +1,20 @@
+inherit gpe
+
+DESCRIPTION = "Touchscreen device detection utility"
+LICENSE = "GPL"
+MAINTAINER = "Rene Wagner <rw@handhelds.org>"
+SECTION = "base"
+
+SRC_URI = "${GPE_MIRROR}/detect-stylus-${PV}.tar.gz \
+ file://access.patch;patch=1;pnum=0 \
+ file://extra-device-check.patch;patch=1 \
+ file://correct-theme-name.patch;patch=1 \
+ file://nox.patch;patch=1"
+S = "${WORKDIR}/detect-stylus-${PV}"
+
+export CVSBUILD = "no"
+export NOX = "yes"
+
+do_install_append () {
+ mv ${D}${bindir}/detect-stylus ${D}${bindir}/detect-tsdevice
+}
diff --git a/packages/detect-stylus/files/.mtn2git_empty b/packages/detect-stylus/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/detect-stylus/files/.mtn2git_empty
diff --git a/packages/detect-stylus/access.patch b/packages/detect-stylus/files/access.patch
index cd8c52074d..cd8c52074d 100644
--- a/packages/detect-stylus/access.patch
+++ b/packages/detect-stylus/files/access.patch
diff --git a/packages/detect-stylus/detect-stylus-0.13/correct-theme-name.patch b/packages/detect-stylus/files/correct-theme-name.patch
index 7c8213da1f..7c8213da1f 100644
--- a/packages/detect-stylus/detect-stylus-0.13/correct-theme-name.patch
+++ b/packages/detect-stylus/files/correct-theme-name.patch
diff --git a/packages/detect-stylus/detect-stylus-0.13/extra-device-check.patch b/packages/detect-stylus/files/extra-device-check.patch
index 94542b11aa..94542b11aa 100644
--- a/packages/detect-stylus/detect-stylus-0.13/extra-device-check.patch
+++ b/packages/detect-stylus/files/extra-device-check.patch
diff --git a/packages/detect-stylus/files/nox.patch b/packages/detect-stylus/files/nox.patch
new file mode 100644
index 0000000000..8bee53613f
--- /dev/null
+++ b/packages/detect-stylus/files/nox.patch
@@ -0,0 +1,86 @@
+Only in detect-stylus-0.13: .pc
+diff -ur detect-stylus-0.13.orig/Makefile detect-stylus-0.13/Makefile
+--- detect-stylus-0.13.orig/Makefile 2004-09-08 17:57:37.000000000 +0200
++++ detect-stylus-0.13/Makefile 2006-04-18 21:00:57.000000000 +0200
+@@ -15,7 +15,11 @@
+ PACKAGE_CFLAGS += -Os -fomit-frame-pointer
+ endif
+ PACKAGE_CPPFLAGS += -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\"
++ifeq ($(NOX),yes)
++PACKAGE_CPPFLAGS += -DNOX
++else
+ PACKAGE_LDFLAGS += `pkg-config --libs x11`
++endif
+
+ OBJS = $(patsubst %,%.o,$(MEMBERS))
+
+@@ -36,8 +40,7 @@
+ mkdir -p $(DESTDIR)$(PREFIX)/bin/
+ $(STRIP) $(PACKAGE)
+ install $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+- mkdir -p $(DESTDIR)/etc/X11/Xinit.d
+- install 70detect-stylus $(DESTDIR)/etc/X11/Xinit.d
++ if [ -z $(NOX) ]; then mkdir -p $(DESTDIR)/etc/X11/Xinit.d && install -m 0755 70detect-stylus $(DESTDIR)/etc/X11/Xinit.d; fi
+
+ clean:
+ rm -f $(PACKAGE) $(OBJS)
+Only in detect-stylus-0.13: detect-stylus
+diff -ur detect-stylus-0.13.orig/detect-stylus.c detect-stylus-0.13/detect-stylus.c
+--- detect-stylus-0.13.orig/detect-stylus.c 2006-04-18 20:22:13.000000000 +0200
++++ detect-stylus-0.13/detect-stylus.c 2006-04-19 21:18:09.000000000 +0200
+@@ -14,8 +14,10 @@
+ #include <dirent.h>
+ #include <string.h>
+
++#ifndef NOX
+ #include <X11/Xlib.h>
+ #include <X11/Xatom.h>
++#endif /* NOX */
+
+ #include <linux/input.h>
+
+@@ -42,11 +44,14 @@
+ int
+ main (int argc, char *argv[])
+ {
++#ifndef NOX
+ char b = 1;
+- char *tsdev;
+ Atom atom;
+ Display *dpy;
+ Window root;
++#endif /* NOX */
++
++ char *tsdev;
+ int fd;
+ int i;
+
+@@ -55,6 +60,8 @@
+ if (!strcmp (argv[i], "--device"))
+ flag_device = 1;
+ }
++ if (strstr (argv[0], "detect-tsdevice"))
++ flag_device = 1;
+
+ fd = try_open ("/dev/touchscreen/0");
+
+@@ -119,6 +126,10 @@
+ if (flag_device)
+ exit (1); /* Nothing found */
+
++#ifdef NOX
++ fprintf (stderr, "This version of detect-stylus was compiled without X support.");
++ exit (1);
++#else
+ if (fd >= 0)
+ {
+ close (fd);
+@@ -141,4 +152,5 @@
+ }
+
+ exit (0);
++#endif /* NOX */
+ }
+Only in detect-stylus-0.13.orig/: detect-stylus.c.orig
+Only in detect-stylus-0.13: detect-stylus.o
+Only in detect-stylus-0.13: patches
diff --git a/packages/gpe-bluetooth/files/fix-resume-script-name.patch b/packages/gpe-bluetooth/files/fix-resume-script-name.patch
new file mode 100644
index 0000000000..7899afc82f
--- /dev/null
+++ b/packages/gpe-bluetooth/files/fix-resume-script-name.patch
@@ -0,0 +1,18 @@
+--- gpe-bluetooth/Makefile.am 2006/01/15 14:24:00 1.15
++++ gpe-bluetooth/Makefile.am 2006/04/20 11:19:17 1.16
+@@ -46,7 +46,7 @@ pixmaps_extradir = $(datadir)/pixmaps
+ btscriptdir = $(sysconfdir)/bluetooth
+ btscript_SCRIPTS = hciattach.sh
+
+-btresumedir = $(sysconfdir)/apm/resume.d
++btresumedir = $(sysconfdir)/apm/scripts.d
+ btresume_SCRIPTS = gpe-bluetooth-resume.sh
+
+ pingladedir = $(datadir)/bluez-pin
+@@ -83,3 +83,6 @@ install-data-hook:
+ cd $(DESTDIR)$(sysconfdir)/bluetooth && mv hciattach.sh hciattach
+ chmod u+s $(DESTDIR)$(gpebluetoothlibdir)/bnep-helper
+ chmod u+s $(DESTDIR)$(gpebluetoothlibdir)/rfcomm-helper
++ mkdir -p $(DESTDIR)$(sysconfdir)/apm/resume.d
++ cd $(DESTDIR)$(sysconfdir)/apm/resume.d/ && ln -sf ../scripts.d/gpe-bluetooth-resume.sh 50-gpe-bluetooth-resume
++
diff --git a/packages/gpe-bluetooth/gpe-bluetooth_0.51.bb b/packages/gpe-bluetooth/gpe-bluetooth_0.51.bb
index 33bd45d1cc..e02318eaf4 100644
--- a/packages/gpe-bluetooth/gpe-bluetooth_0.51.bb
+++ b/packages/gpe-bluetooth/gpe-bluetooth_0.51.bb
@@ -2,6 +2,7 @@ LICENSE = "GPL"
DESCRIPTION = "GPE bluetooth support"
SECTION = "gpe"
PRIORITY = "optional"
+PR = "r1"
DEPENDS = "gtk+ libcontactsdb libdisplaymigration libgpewidget openobex libgpevtype bluez-libs sqlite dbus libglade blueprobe bluez-utils-dbus"
RDEPENDS = "bluez-utils-dbus blueprobe"
@@ -9,4 +10,6 @@ RDEPENDS = "bluez-utils-dbus blueprobe"
GPE_TARBALL_SUFFIX= "bz2"
inherit gpe autotools
+SRC_URI += "file://fix-resume-script-name.patch;patch=1"
+
FILES_${PN} += '${datadir}/bluez-pin'
diff --git a/packages/gpe-plucker/gpe-plucker/gpe-plucker-desktop.patch b/packages/gpe-plucker/gpe-plucker/gpe-plucker-desktop.patch
new file mode 100644
index 0000000000..1343bb739f
--- /dev/null
+++ b/packages/gpe-plucker/gpe-plucker/gpe-plucker-desktop.patch
@@ -0,0 +1,17 @@
+--- gpe-plucker-0.2/gpe-plucker.desktop.in.orig 2006-02-14 20:59:49.000000000 +0200
++++ gpe-plucker-0.2/gpe-plucker.desktop.in 2006-02-14 20:37:22.000000000 +0200
+@@ -1,9 +1,10 @@
+ [Desktop Entry]
+-_Name=Plucker
+-_Comment=Plucker Reader
++Encoding=UTF-8
++_Name=E-book Reader
++_Comment=Plucker E-book Reader
+ Exec=gpe-plucker
+-Terminal=0
++Terminal=false
+ Type=Application
+ Icon=gpe-plucker.png
+-Categories=Application;GPE
++Categories=Application;GPE;
+ SingleInstance=true
diff --git a/packages/gpe-plucker/gpe-plucker_0.2.bb b/packages/gpe-plucker/gpe-plucker_0.2.bb
index 850319d86d..46610cc71a 100644
--- a/packages/gpe-plucker/gpe-plucker_0.2.bb
+++ b/packages/gpe-plucker/gpe-plucker_0.2.bb
@@ -4,9 +4,11 @@ DESCRIPTION = "Plucker ebook reader"
DEPENDS = "gtk+ libgpewidget"
SECTION = "gpe"
PRIORITY = "optional"
+PR = "r1"
PARALLEL_MAKE=""
SRC_URI += "file://fix_makefiles.patch;patch=1 \
- file://remove-render.patch;patch=1"
+ file://remove-render.patch;patch=1 \
+ file://gpe-plucker-desktop.patch;patch=1"
diff --git a/packages/libsdl/libsdl-mixer_1.2.6.bb b/packages/libsdl/libsdl-mixer_1.2.6.bb
index 3aafa18d0c..7e76334e99 100644
--- a/packages/libsdl/libsdl-mixer_1.2.6.bb
+++ b/packages/libsdl/libsdl-mixer_1.2.6.bb
@@ -4,7 +4,7 @@ PRIORITY = "optional"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
DEPENDS = "virtual/libsdl"
LICENSE = "LGPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz"
S = "${WORKDIR}/SDL_mixer-${PV}"
@@ -13,7 +13,7 @@ export SDL_CONFIG = "${STAGING_BINDIR}/sdl-config"
inherit autotools
-EXTRA_OECONF = "--disable-music-mp3 --disable-music-libmikmod"
+EXTRA_OECONF = "--disable-music-mp3 --disable-music-libmikmod --disable-music-ogg"
# although we build smpeg... need to find out how
# to deal with optional dependencies
diff --git a/packages/linux/handhelds-pxa-2.6_2.6.15-hh1.bb b/packages/linux/handhelds-pxa-2.6_2.6.15-hh1.bb
new file mode 100644
index 0000000000..983d59fd28
--- /dev/null
+++ b/packages/linux/handhelds-pxa-2.6_2.6.15-hh1.bb
@@ -0,0 +1,35 @@
+SECTION = "kernel"
+DESCRIPTION = "handhelds.org Linux kernel for PXA based devices."
+MAINTAINER = "Greg Gilbert <greg@treke.net>"
+LICENSE = "GPL"
+
+COMPATIBLE_HOST = "arm.*-linux"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/handhelds-pxa-${PV}"
+
+SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')} \
+ file://defconfig"
+
+S = "${WORKDIR}/kernel26"
+
+inherit kernel
+
+K_MAJOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[0]}"
+K_MINOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[1]}"
+K_MICRO = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[2]}"
+HHV = "${@bb.data.getVar('PV',d,1).split('-')[1].split('hh')[-1]}"
+
+KERNEL_PRIORITY = "${@'%d' % (int(bb.data.getVar('K_MAJOR',d,1)) * 100000000 + int(bb.data.getVar('K_MINOR',d,1)) * 1000000 + int(bb.data.getVar('K_MICRO',d,1)) * 10000 + float(bb.data.getVar('HHV',d,1)))}"
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config || die "No default configuration for ${MACHINE} available."
+ yes '' | oe_runmake oldconfig
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR}/images
+ install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile
diff --git a/packages/linux/handhelds-pxa_2.4.19-rmk6-pxa1-hh41.bb b/packages/linux/handhelds-pxa_2.4.19-rmk6-pxa1-hh41.bb
index 2e301a172d..b360ac3674 100644
--- a/packages/linux/handhelds-pxa_2.4.19-rmk6-pxa1-hh41.bb
+++ b/packages/linux/handhelds-pxa_2.4.19-rmk6-pxa1-hh41.bb
@@ -3,10 +3,9 @@ DESCRIPTION = "handhelds.org Linux kernel for PXA25x based devices."
MAINTAINER = "Phil Blundell <pb@handhelds.org>"
LICENSE = "GPL"
PR = "r0"
-DEFAULT_PREFERENCE="-1"
-KERNEL_CCSUFFIX = "-3.3.3"
+KERNEL_CCSUFFIX = "-3.3.4"
COMPATIBLE_HOST = "arm.*-linux"
SRC_URI = "${HANDHELDS_CVS};module=linux/kernel;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')} \
diff --git a/packages/python/python-pygtk2_2.6.2.bb b/packages/python/python-pygtk2_2.6.2.bb
index d24ab38434..3a26fb6cdf 100644
--- a/packages/python/python-pygtk2_2.6.2.bb
+++ b/packages/python/python-pygtk2_2.6.2.bb
@@ -3,9 +3,10 @@ SECTION = "devel/python"
PRIORITY = "optional"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
DEPENDS = "gtk+ libglade"
+RDEPENDS = "python-shell"
SRCNAME = "pygtk"
LICENSE = "LGPL"
-PR = "r3"
+PR = "r4"
SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.6/${SRCNAME}-${PV}.tar.bz2 \
file://obey-path.patch;patch=1 \
diff --git a/packages/python/python_2.4.2.bb b/packages/python/python_2.4.2.bb
index f065b68112..db83440ad5 100644
--- a/packages/python/python_2.4.2.bb
+++ b/packages/python/python_2.4.2.bb
@@ -4,7 +4,7 @@ LICENSE = "PSF"
SECTION = "devel/python"
PRIORITY = "optional"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-DEPENDS = "python-native readline zlib gdbm openssl tcl tk"
+DEPENDS = "python-native readline zlib gdbm tcl tk"
PR = "ml4"
PYTHON_MAJMIN = "2.4"
@@ -62,6 +62,8 @@ do_install() {
include python-${PV}-manifest.inc
-PACKAGES =+ "libpython2"
+PACKAGES =+ "libpython2 ${PN}"
FILES_libpython2 = "${libdir}/libpython*"
-
+FILES_${PN} = ""
+ALLOW_EMPTY_${PN} = "1"
+RDEPENDS_${PN} = "python-core"
diff --git a/packages/tslib/tslib/h1940/tslib.sh b/packages/tslib/tslib/h1940/tslib.sh
index 5e5e283962..6183d43fba 100644
--- a/packages/tslib/tslib/h1940/tslib.sh
+++ b/packages/tslib/tslib/h1940/tslib.sh
@@ -1,6 +1,6 @@
#!/bin/sh
-TSLIB_TSDEVICE=`detect-stylus --device`
+TSLIB_TSDEVICE=`detect-tsdevice`
TSLIB_CONFFILE=/usr/share/tslib/ts.conf-h3600
QWS_MOUSE_PROTO=TPanel
diff --git a/packages/tslib/tslib/h2200/tslib.sh b/packages/tslib/tslib/h2200/tslib.sh
index be9448b1dc..7fa6492ce0 100644
--- a/packages/tslib/tslib/h2200/tslib.sh
+++ b/packages/tslib/tslib/h2200/tslib.sh
@@ -10,7 +10,7 @@ case `uname -r` in
TSLIB_CONFFILE=/usr/share/tslib/ts.conf-h3600-2.4
;;
*)
- TSLIB_TSDEVICE=`detect-stylus --device`
+ TSLIB_TSDEVICE=`detect-tsdevice`
TSLIB_CONFFILE=/usr/share/tslib/ts.conf-h3600
;;
esac
diff --git a/packages/tslib/tslib/h3600/tslib.sh b/packages/tslib/tslib/h3600/tslib.sh
index 5c446c2610..b07fce0aea 100644
--- a/packages/tslib/tslib/h3600/tslib.sh
+++ b/packages/tslib/tslib/h3600/tslib.sh
@@ -6,7 +6,7 @@ case `uname -r` in
TSLIB_CONFFILE=/usr/share/tslib/ts.conf-h3600-2.4
;;
*)
- TSLIB_TSDEVICE=`detect-stylus --device`
+ TSLIB_TSDEVICE=`detect-tsdevice`
TSLIB_CONFFILE=/usr/share/tslib/ts.conf-h3600
;;
esac
diff --git a/packages/tslib/tslib/h3900/tslib.sh b/packages/tslib/tslib/h3900/tslib.sh
index be9448b1dc..7fa6492ce0 100644
--- a/packages/tslib/tslib/h3900/tslib.sh
+++ b/packages/tslib/tslib/h3900/tslib.sh
@@ -10,7 +10,7 @@ case `uname -r` in
TSLIB_CONFFILE=/usr/share/tslib/ts.conf-h3600-2.4
;;
*)
- TSLIB_TSDEVICE=`detect-stylus --device`
+ TSLIB_TSDEVICE=`detect-tsdevice`
TSLIB_CONFFILE=/usr/share/tslib/ts.conf-h3600
;;
esac
diff --git a/packages/tslib/tslib/h6300/tslib.sh b/packages/tslib/tslib/h6300/tslib.sh
index 21aaad9ca4..95e6a2d02b 100644
--- a/packages/tslib/tslib/h6300/tslib.sh
+++ b/packages/tslib/tslib/h6300/tslib.sh
@@ -1,6 +1,6 @@
#!/bin/sh
-TSLIB_TSDEVICE=`detect-stylus --device`
+TSLIB_TSDEVICE=`detect-tsdevice`
TSLIB_CONFFILE=/usr/share/tslib/ts.conf-h6300
export TSLIB_TSDEVICE TSLIB_CONFFILE
diff --git a/packages/tslib/tslib/ipaq-pxa270/tslib.sh b/packages/tslib/tslib/ipaq-pxa270/tslib.sh
index 72ebcba7c2..a3eb096a30 100644
--- a/packages/tslib/tslib/ipaq-pxa270/tslib.sh
+++ b/packages/tslib/tslib/ipaq-pxa270/tslib.sh
@@ -1,6 +1,6 @@
#!/bin/sh
-TSLIB_TSDEVICE=`detect-stylus --device`
+TSLIB_TSDEVICE=`detect-tsdevice`
TSLIB_CONFFILE=/usr/share/tslib/ts.conf-h3600
export TSLIB_TSDEVICE TSLIB_CONFFILE
diff --git a/packages/tslib/tslib_cvs.bb b/packages/tslib/tslib_cvs.bb
index 0a79a492a3..53b4a0217c 100644
--- a/packages/tslib/tslib_cvs.bb
+++ b/packages/tslib/tslib_cvs.bb
@@ -1,12 +1,26 @@
SECTION = "base"
DESCRIPTION = "tslib is a touchscreen access library."
PV = "0.0cvs${CVSDATE}"
-PR = "r32"
+PR = "r33"
SRC_URI_OVERRIDES_PACKAGE_ARCH = "0"
PACKAGE_ARCH_tslib-conf = "${MACHINE}"
PACKAGE_ARCH_mnci = "${MACHINE}"
+DEPENDS_h1940_append = " detect-tsdevice"
+DEPENDS_h2200_append = " detect-tsdevice"
+DEPENDS_h3600_append = " detect-tsdevice"
+DEPENDS_h3900_append = " detect-tsdevice"
+DEPENDS_h6300_append = " detect-tsdevice"
+DEPENDS_ipaq-pxa270_append = " detect-tsdevice"
+
+RDEPENDS_tslib-conf_h1940_append = " detect-tsdevice"
+RDEPENDS_tslib-conf_h2200_append = " detect-tsdevice"
+RDEPENDS_tslib-conf_h3600_append = " detect-tsdevice"
+RDEPENDS_tslib-conf_h3900_append = " detect-tsdevice"
+RDEPENDS_tslib-conf_h6300_append = " detect-tsdevice"
+RDEPENDS_tslib-conf_ipaq-pxa270_append = " detect-tsdevice"
+
SRC_URI = "cvs://cvs:@pubcvs.arm.linux.org.uk/mnt/src/cvsroot;module=tslib \
file://ts.conf \
file://ts.conf-h3600 file://ts.conf-h3600-2.4 file://ts.conf-h6300 \
diff --git a/packages/udev/udev-084/local.rules b/packages/udev/udev-084/local.rules
new file mode 100644
index 0000000000..bb8459ba23
--- /dev/null
+++ b/packages/udev/udev-084/local.rules
@@ -0,0 +1,28 @@
+# There are a number of modifiers that are allowed to be used in some
+# of the different fields. They provide the following subsitutions:
+#
+# %n the "kernel number" of the device.
+# For example, 'sda3' has a "kernel number" of '3'
+# %e the smallest number for that name which does not matches an existing node
+# %k the kernel name for the device
+# %M the kernel major number for the device
+# %m the kernel minor number for the device
+# %b the bus id for the device
+# %c the string returned by the PROGRAM
+# %s{filename} the content of a sysfs attribute
+# %% the '%' char itself
+#
+
+# Media automounting
+SUBSYSTEM=="block", ACTION=="add" RUN+="/etc/udev/scripts/mount.sh"
+SUBSYSTEM=="block", ACTION=="remove" RUN+="/etc/udev/scripts/mount.sh"
+
+# Handle network interface setup
+SUBSYSTEM=="net", ACTION=="add" RUN+="/etc/udev/scripts/network.sh"
+SUBSYSTEM=="net", ACTION=="remove" RUN+="/etc/udev/scripts/network.sh"
+
+# The first rtc device is symlinked to /dev/rtc
+KERNEL="rtc0", SYMLINK="rtc"
+
+# Try and modprobe for drivers for new hardware
+ACTION="add", DEVPATH="/devices/*", MODALIAS=="?*", RUN+="/sbin/modprobe $modalias"
diff --git a/packages/udev/udev-084/udev.rules b/packages/udev/udev-084/udev.rules
index 6308cb0918..7b4152c5bf 100644
--- a/packages/udev/udev-084/udev.rules
+++ b/packages/udev/udev-084/udev.rules
@@ -28,7 +28,7 @@ BUS=="usb", KERNEL=="ttyUSB*", SYSFS{product}=="Palm Handheld*", \
# usbfs-like devices
SUBSYSTEM=="usb_device", \
- PROGRAM="/bin/sh -c 'X=%k X=$${X#usbdev} B=$${X%%%%.*} D=$${X#*.}; echo bus/usb/$$B/$$D'", SYMLINK+="%c"
+ PROGRAM="/bin/sh -c 'export X=%k; export X=$${X#usbdev}; export B=$${X%%%%.*}; export D=$${X#*.}; echo bus/usb/$$B/$$D'", SYMLINK+="%c"
# serial devices
KERNEL=="capi", NAME="capi20", SYMLINK+="isdn/capi20"
diff --git a/packages/udev/udev_084.bb b/packages/udev/udev_084.bb
index 904f73783c..6bafa615d7 100644
--- a/packages/udev/udev_084.bb
+++ b/packages/udev/udev_084.bb
@@ -1,5 +1,3 @@
-DEFAULT_PREFERENCE = "-1"
-
DESCRIPTION = "udev is a daemon which dynamically creates and removes device nodes from \
/dev/, handles hotplug events and loads drivers at boot time. It replaces \
the hotplug package and requires a kernel not older than 2.6.12."
@@ -15,7 +13,7 @@ include udev.inc
INITSCRIPT_PARAMS = "start 03 S . start 55 0 6 ."
-PR = "r1"
+PR = "r3"
FILES_${PN} += "${base_libdir}"
UDEV_EXTRAS = "extras/firmware/ extras/scsi_id/ extras/volume_id/ extras/run_directory/"
diff --git a/packages/xstroke/xstroke_0.6.bb b/packages/xstroke/xstroke_0.6.bb
index c905b7b601..31542e855c 100644
--- a/packages/xstroke/xstroke_0.6.bb
+++ b/packages/xstroke/xstroke_0.6.bb
@@ -6,7 +6,7 @@ MAINTAINER = "Phil Blundell <pb@handhelds.org>"
DEPENDS = "x11 xft xtst xpm"
PR = "r2"
-SRC_URI = "http://xstroke.org/releases/xstroke-0.6.tar.gz \
+SRC_URI = "http://www.oesources.org/source/xstroke-0.6.tar.gz \
file://auto-disable.patch;patch=1;pnum=0"
inherit autotools pkgconfig
diff --git a/packages/xstroke/xstroke_cvs.bb b/packages/xstroke/xstroke_cvs.bb
deleted file mode 100644
index 43efdf2965..0000000000
--- a/packages/xstroke/xstroke_cvs.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-DESCRIPTION = "Gesture recognition input method for X11"
-LICENSE = "GPL"
-SECTION = "x11"
-PRIORITY = "optional"
-MAINTAINER = "Phil Blundell <pb@handhelds.org>"
-DEPENDS = "x11 xft xtst xpm"
-PV = "0.0cvs${CVSDATE}"
-PR = "r1"
-
-SRC_URI = "cvs://anoncvs:anoncvs@xstroke.org/cvs/xstroke;module=xstroke"
-S = "${WORKDIR}/xstroke"
-
-inherit autotools pkgconfig