aboutsummaryrefslogtreecommitdiffstats
path: root/packages/wrt
diff options
context:
space:
mode:
Diffstat (limited to 'packages/wrt')
-rw-r--r--packages/wrt/wrt-init.bb16
-rw-r--r--packages/wrt/wrt-init/mount6
2 files changed, 22 insertions, 0 deletions
diff --git a/packages/wrt/wrt-init.bb b/packages/wrt/wrt-init.bb
index e69de29bb2..bbb19f8c58 100644
--- a/packages/wrt/wrt-init.bb
+++ b/packages/wrt/wrt-init.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "wrt init scripts"
+SECTION = "base"
+LICENSE = "GPL"
+
+SRC_URI = "file://mount file://wrtboot"
+
+do_install() {
+ install -d ${D}${sysconfdir}/rcS.d \
+ ${D}${sysconfdir}/init.d
+
+ install -m 0755 ${WORKDIR}/mount ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/wrtboot ${D}${sysconfdir}/init.d
+
+ ln -s ../init.d/mount ${D}${sysconfdir}/rcS.d/S05mount
+ ln -s ../init.d/wrtboot ${D}${sysconfdir}/rcS.d/S10wrtboot
+}
diff --git a/packages/wrt/wrt-init/mount b/packages/wrt/wrt-init/mount
index e69de29bb2..539dbfad59 100644
--- a/packages/wrt/wrt-init/mount
+++ b/packages/wrt/wrt-init/mount
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+mount -o remount,rw /
+mount /proc
+mount /var
+mount /dev/pts