aboutsummaryrefslogtreecommitdiffstats
path: root/packages/unik-olsrd/unik-olsrd_cvs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/unik-olsrd/unik-olsrd_cvs.bb')
-rw-r--r--packages/unik-olsrd/unik-olsrd_cvs.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/packages/unik-olsrd/unik-olsrd_cvs.bb b/packages/unik-olsrd/unik-olsrd_cvs.bb
index e69de29bb2..122f76cc53 100644
--- a/packages/unik-olsrd/unik-olsrd_cvs.bb
+++ b/packages/unik-olsrd/unik-olsrd_cvs.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "OLSR mesh routing daemon"
+HOMEPAGE = "http://www.olsr.org"
+DESCRIPTION_unik-olsrd-libs = "OLSR mesh routing daemon - optional libraries"
+MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "BSD"
+PV = "cvs${CVSDATE}"
+
+SRC_URI="cvs://anonymous@cvs.sourceforge.net/cvsroot/olsrd;module=olsrd-current \
+ file://unik-olsrd \
+ file://olsrd.conf"
+
+PACKAGES =+ "unik-olsrd-libs"
+FILES_unik-olsrd-libs = "${libdir}"
+
+S = "${WORKDIR}/olsrd-current"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "unik-olsrd"
+INITSCRIPT_PARAMS = "defaults"
+
+do_compile() {
+ touch .depend
+ touch src/cfgparser/.depend
+ oe_runmake OS=linux clean all libs
+}
+
+do_install () {
+ oe_runmake INSTALL_PREFIX=${D} install install_libs
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/unik-olsrd ${D}/${sysconfdir}/init.d
+ install -m 644 ${WORKDIR}/olsrd.conf ${D}/${sysconfdir}
+}
+
+CONFFILES_${PN} = "${sysconfdir}/olsrd.conf"