aboutsummaryrefslogtreecommitdiffstats
path: root/packages/twisted/twisted_8.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/twisted/twisted_8.2.0.bb')
-rw-r--r--packages/twisted/twisted_8.2.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/packages/twisted/twisted_8.2.0.bb b/packages/twisted/twisted_8.2.0.bb
new file mode 100644
index 0000000000..5661b762ee
--- /dev/null
+++ b/packages/twisted/twisted_8.2.0.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Twisted is an event-driven networking framework written in Python and licensed under the LGPL. \
+Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols \
+(including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more."
+HOMEPAGE = "http://www.twistedmatrix.com"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "zope-interface-native zope-interface python-crypto twisted-native"
+RDEPENDS = "python-core zope-interface python-pickle python-fcntl python-crypto"
+
+SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Twisted/8.2/Twisted-${PV}.tar.bz2"
+
+S = "${WORKDIR}/Twisted-${PV}"
+
+inherit distutils
+
+SP = "${libdir}/${PYTHON_DIR}/site-packages/twisted"
+
+FILES_twisted-conch = "${SP}/conch/"
+FILES_twisted-lore = "${SP}/lore/"
+FILES_twisted-mail = "${SP}/mail/"
+FILES_twisted-names = "${SP}/names/"
+FILES_twisted-news = "${SP}/news/"
+FILES_twisted-runner = "${SP}/runner/"
+FILES_twisted-web = "${SP}/web/"
+FILES_twisted-words = "${SP}/words/"
+FILES_twisted-trial = "${SP}/trial/ ${SP}/test/"
+PACKAGES = "twisted-conch twisted-lore twisted-mail twisted-names twisted-news twisted-runner twisted-web twisted-words twisted-trial twisted"
+
+do_compile_prepend() {
+ export PYTHONPATH=${S}/TwistedCore-${PV}
+}
+
+do_install_prepend() {
+ export PYTHONPATH=${S}/TwistedCore-${PV}
+}