aboutsummaryrefslogtreecommitdiffstats
path: root/packages/taglib/taglib_1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/taglib/taglib_1.4.bb')
-rw-r--r--packages/taglib/taglib_1.4.bb43
1 files changed, 13 insertions, 30 deletions
diff --git a/packages/taglib/taglib_1.4.bb b/packages/taglib/taglib_1.4.bb
index 43fb2a2bfa..e50eeb6490 100644
--- a/packages/taglib/taglib_1.4.bb
+++ b/packages/taglib/taglib_1.4.bb
@@ -1,41 +1,24 @@
DESCRIPTION = "TagLib is a library for reading and editing the meta-data of several popular audio formats"
-SECTION = "libs"
+SECTION = "libs/multimedia"
HOMEPAGE = "http://developer.kde.org/~wheeler/taglib.html"
LICENSE = "LGPL"
-PR = "r1"
+PR = "r2"
-SRC_URI = "http://developer.kde.org/~wheeler/files/src/taglib-${PV}.tar.gz"
+SRC_URI = "http://developer.kde.org/~wheeler/files/src/taglib-${PV}.tar.gz \
+ file://taglib_1.4-8.diff.gz;patch=1"
S = "${WORKDIR}/taglib-${PV}"
-inherit autotools qmake_base pkgconfig binconfig
+inherit autotools pkgconfig binconfig
-export OE_QMAKE_LINK="${CXX}"
-
-do_configure() {
- # calling oe_runconf to generate pkgconfig and binconfig files
- oe_runconf
- cd ${S}/taglib && rm -f Makefile* && qmake -project -o tag.pro -t lib && \
- qmake -spec ${QMAKESPEC} -after CONFIG=console INCLUDEPATH+=${S}
-}
-
-do_compile() {
- oe_runmake -C taglib
+do_postpatch() {
+ rm -rf patches && rm -rf .pc && mv -f debian/patches patches && quilt push -av
}
+addtask postpatch after do_patch before do_configure
-do_stage_append() {
- install -d ${STAGING_INCDIR}/taglib
- for i in `find taglib -name "*.h"`
- do
- install $i ${STAGING_INCDIR}/taglib/
- done
- for i in `find taglib -name "*.tcc"`
- do
- install $i ${STAGING_INCDIR}/taglib/
- done
- oe_libinstall -so -C taglib libtag ${STAGING_LIBDIR}
+do_stage() {
+ autotools_stage_all
}
-do_install() {
- install -d ${D}${libdir}
- oe_libinstall -so -C taglib libtag ${D}${libdir}
-}
+PACKAGES =+ "${PN}-c"
+FILES_${PN}-dbg += "${bindir}/taglib-config"
+FILES_${PN}-c = "${libdir}/libtag_c.so.*"