aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python
diff options
context:
space:
mode:
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-sword_1.5.9.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/python/python-sword_1.5.9.bb b/packages/python/python-sword_1.5.9.bb
new file mode 100644
index 0000000000..6c777bb54d
--- /dev/null
+++ b/packages/python/python-sword_1.5.9.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Python bindings for the sword library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "python-core sword"
+DEPENDS = "sword-${PV} swig-native"
+SRCNAME = "sword"
+PR = "r0"
+
+SRC_URI = "http://crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}/bindings/swig/package"
+
+EXTRA_OECONF = "--with-sword-dir=${STAGING_DIR}/${HOST_SYS}"
+
+inherit distutils autotools
+
+PARALLEL_MAKE = ""
+
+#do_configure_prepend() {
+# ./autogen.sh
+#}
+
+do_compile() {
+ oe_runmake BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} pythonswig python_make
+}
+
+do_install() {
+ cd ${S}/python
+ distutils_do_install
+}