aboutsummaryrefslogtreecommitdiffstats
path: root/packages/psplash/psplash_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/psplash/psplash_svn.bb')
-rw-r--r--packages/psplash/psplash_svn.bb22
1 files changed, 13 insertions, 9 deletions
diff --git a/packages/psplash/psplash_svn.bb b/packages/psplash/psplash_svn.bb
index eebe2179da..6e117db941 100644
--- a/packages/psplash/psplash_svn.bb
+++ b/packages/psplash/psplash_svn.bb
@@ -1,26 +1,28 @@
DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
SECTION = "base"
LICENSE = "GPL"
-
PV = "0.0+svn${SRCDATE}"
-PR = "r2"
+PR = "r8"
# You can create your own pslash-hand-img.h by doing
# ./make-image-header.sh <file>.png HAND
-# and rename the resulting .h to pslash-hand-img.h
+# and rename the resulting .h to pslash-hand-img.h (for the logo)
+# respectively psplash-bar-img.h (BAR) for the bar.
+# You might also want to patch the colors (see patch)
SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
- file://psplash-hand-img.h \
- file://psplash-init"
-
+ file://psplash-hand-img.h \
+ file://psplash-bar-img.h \
+ file://psplash-init"
S = "${WORKDIR}/psplash"
-inherit autotools pkgconfig update-rc.d
+SRC_URI_append_openmoko = " file://configurability.patch;patch=1 "
-FILES_${PN} += "/mnt/.psplash"
+inherit autotools pkgconfig update-rc.d
do_configure_append() {
- cp ${WORKDIR}/psplash-hand-img.h ${S}/
+ install -m 0644 ${WORKDIR}/psplash-hand-img.h ${S}/
+ install -m 0644 ${WORKDIR}/psplash-bar-img.h ${S}/
}
do_install_prepend() {
@@ -31,3 +33,5 @@ do_install_prepend() {
INITSCRIPT_NAME = "psplash"
INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."
+
+FILES_${PN} += "/mnt/.psplash"