aboutsummaryrefslogtreecommitdiffstats
path: root/packages/pcre
diff options
context:
space:
mode:
Diffstat (limited to 'packages/pcre')
-rw-r--r--packages/pcre/pcre_4.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/pcre/pcre_4.4.bb b/packages/pcre/pcre_4.4.bb
index e69de29bb2..3bc316320f 100644
--- a/packages/pcre/pcre_4.4.bb
+++ b/packages/pcre/pcre_4.4.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Perl-compatible regular expression library. PCRE has its own native \
+API, but a set of 'wrapper' functions that are based on the POSIX API \
+are also supplied in the library libpcreposix. Note that this just \
+provides a POSIX calling interface to PCRE; the regular expressions \
+themselves still follow Perl syntax and semantics. The header file for \
+the POSIX-style functions is called pcreposix.h."
+SECTION = "devel"
+PR = "r1"
+LICENSE = "BSD"
+SRC_URI = "ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-${PV}.tar.bz2"
+S = "${WORKDIR}/pcre-${PV}"
+
+inherit autotools binconfig
+
+LEAD_SONAME = "libpcre.so"
+CFLAGS_append = " -D_REENTRANT"
+EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10000000"
+
+do_compile () {
+ ${BUILD_CC} -DLINK_SIZE=2 -I${S}/include -c dftables.c
+ ${BUILD_CC} dftables.o -o dftables
+ oe_runmake
+}
+
+do_stage () {
+ oe_libinstall -a -so libpcreposix ${STAGING_LIBDIR}
+ oe_libinstall -a -so libpcre ${STAGING_LIBDIR}
+ install -m 0644 pcre.h ${STAGING_INCDIR}/
+ install -m 0644 pcreposix.h ${STAGING_INCDIR}/
+}
+
+FILES_${PN} = "${libdir}/lib*.so*"
+FILES_${PN}-dev += "${bindir}"