summaryrefslogtreecommitdiffstats
path: root/packages/nslu2-binary-only/nslu2-switchbox-firmware.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/nslu2-binary-only/nslu2-switchbox-firmware.bb')
-rw-r--r--packages/nslu2-binary-only/nslu2-switchbox-firmware.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/nslu2-binary-only/nslu2-switchbox-firmware.bb b/packages/nslu2-binary-only/nslu2-switchbox-firmware.bb
index e69de29bb2..ad213e725a 100644
--- a/packages/nslu2-binary-only/nslu2-switchbox-firmware.bb
+++ b/packages/nslu2-binary-only/nslu2-switchbox-firmware.bb
@@ -0,0 +1,20 @@
+SECTION = "base"
+DEPENDS = ""
+PACKAGES = ""
+INHIBIT_DEFAULT_DEPS = "1"
+PR = "r6"
+
+SRC_URI = "http://nslu.sf.net/downloads/switchbox-3.5.tar.gz"
+S = "${WORKDIR}"
+
+python () {
+ # Don't build switchbox firmware unless we're targeting an nslu2
+ mach = bb.data.getVar("MACHINE", d, 1)
+ if mach != 'nslu2':
+ raise bb.parse.SkipPackage("Switchbox is only relevant for the Linksys NSLU2")
+}
+
+do_compile () {
+ install -d ${STAGING_LIBDIR}/nslu2-binaries
+ install -m 0755 switchbox.ext2.gz ${STAGING_LIBDIR}/nslu2-binaries/switchbox.ext2.gz
+}