aboutsummaryrefslogtreecommitdiffstats
path: root/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r25.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/nslu2-binary-only/nslu2-linksys-libs_2.3r25.bb')
-rw-r--r--packages/nslu2-binary-only/nslu2-linksys-libs_2.3r25.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r25.bb b/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r25.bb
index e69de29bb2..b9fd20ac49 100644
--- a/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r25.bb
+++ b/packages/nslu2-binary-only/nslu2-linksys-libs_2.3r25.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Linksys NSLU2 Stock Firmware Libraries."
+PACKAGE_ARCH = "nslu2"
+SECTION = "base"
+PRIORITY = "required"
+PR = "r2"
+
+SRC_URI = "http://nslu.sf.net/downloads/nslu2-linksys-ramdisk-2.3r25.tar.bz2"
+
+S = "${WORKDIR}/nslu2-linksys-ramdisk-2.3r25"
+
+do_install () {
+ ( cd ${S} ; rm -rf bin dev home mnt proc sbin share tmp upload usr var )
+ ( cd ${S} ; tar cvf - . ) | ( cd ${D} ; tar xvf - )
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} = "/lib"
+
+python () {
+ # Don't build unless we're targeting an nslu2
+ if bb.data.getVar("MACHINE", d, 1) != "nslu2":
+ raise bb.parse.SkipPackage("NSLU2 stock firmware libraries only builds for the Linksys NSLU2")
+}