aboutsummaryrefslogtreecommitdiffstats
path: root/packages/nonworking/efl/ewl_0.5.1.008.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/nonworking/efl/ewl_0.5.1.008.bb')
-rw-r--r--packages/nonworking/efl/ewl_0.5.1.008.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/nonworking/efl/ewl_0.5.1.008.bb b/packages/nonworking/efl/ewl_0.5.1.008.bb
new file mode 100644
index 0000000000..3a9313cb59
--- /dev/null
+++ b/packages/nonworking/efl/ewl_0.5.1.008.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "The Enlightened Widget Library, \
+a simple-to-use general purpose widget library based on the enlightenment foundation libraries."
+DEPENDS = "edb virtual/evas virtual/ecore edje"
+# emotion
+RDEPENDS += "ewl-themes"
+LICENSE = "MIT"
+PR = "r1"
+
+inherit efl
+
+SRC_URI += "file://ewl-configure.patch;patch=1 \
+ file://no-examples.patch;patch=1 \
+ file://minmax.patch;patch=1 \
+ ${E_CVS};module=e17/libs/evas/m4;date=20060501"
+
+do_configure_prepend() {
+ if [ -e "${WORKDIR}/m4" ]; then
+ install -d "${S}/m4"
+ install "${WORKDIR}/m4/"*.m4 "${S}/m4"
+ aclocal -I m4
+ fi
+}
+
+do_stage_append() {
+ for i in src/lib/ewl_*.h
+ do
+ install -m 0644 $i ${STAGING_INCDIR}
+ done
+}