aboutsummaryrefslogtreecommitdiffstats
path: root/packages/neon/neon_0.24.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/neon/neon_0.24.7.bb')
-rw-r--r--packages/neon/neon_0.24.7.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/neon/neon_0.24.7.bb b/packages/neon/neon_0.24.7.bb
index e69de29bb2..2e2ba4de59 100644
--- a/packages/neon/neon_0.24.7.bb
+++ b/packages/neon/neon_0.24.7.bb
@@ -0,0 +1,18 @@
+inherit autotools
+
+DEPENDS = "zlib libxml2 expat"
+SECTION = "base"
+LICENSE = "LGPL"
+DESCRIPTION = "neon is an HTTP and WebDAV client library, with a C interface."
+PR = "r1"
+
+SRC_URI = "http://www.webdav.org/neon/neon-0.24.7.tar.gz \
+ file://no-func-checks.patch;patch=1"
+
+EXTRA_OECONF = " --without-ssl --with-libxml2 --with-expat \
+ --enable-shared --enable-static"
+
+do_stage () {
+ autotools_stage_includes
+ oe_libinstall -C src -so -a libneon ${STAGING_LIBDIR}/
+}