aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mythfront/mythfront-config.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/mythfront/mythfront-config.bb')
-rw-r--r--packages/mythfront/mythfront-config.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/mythfront/mythfront-config.bb b/packages/mythfront/mythfront-config.bb
index e69de29bb2..cf89514a71 100644
--- a/packages/mythfront/mythfront-config.bb
+++ b/packages/mythfront/mythfront-config.bb
@@ -0,0 +1,32 @@
+PV = "1.7"
+
+DEPENDS = "xfonts-xorg"
+RDEPENDS_${PN} = "xfonts-xorg"
+LICENSE = "MIT"
+SRC_URI = "file://tftp.sh file://xorg.conf"
+
+SRC_URI_append_epia = " file://serial.sh"
+
+do_install() {
+ install -d ${D}/etc/udhcpc.d/
+ install ${WORKDIR}/tftp.sh ${D}/etc/udhcpc.d/80tftp
+
+ install -d ${D}/etc/mythtv
+ ln -sf /var/lib/config/mysql.txt ${D}/etc/mythtv
+
+ install -d ${D}/etc/X11
+ install -m 0644 ${WORKDIR}/xorg.conf ${D}/etc/X11
+
+ ln -sf /var/lib/config/lircd.conf ${D}/etc/lircd.conf
+
+ install -d ${D}/dev
+ ln -sf lirc0 ${D}/dev/lirc
+
+ if [ -f ${WORKDIR}/serial.sh ]; then
+ install -d ${D}/etc/init.d
+ install -d ${D}/etc/rc2.d
+ install ${WORKDIR}/serial.sh ${D}/etc/init.d/mythfront-serial
+ ln -sf ../init.d/mythfront-serial ${D}/etc/rc2.d/S10mythfront-serial
+ fi
+}
+