aboutsummaryrefslogtreecommitdiffstats
path: root/packages/matchbox2/matchbox-panel-2_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/matchbox2/matchbox-panel-2_svn.bb')
-rw-r--r--packages/matchbox2/matchbox-panel-2_svn.bb15
1 files changed, 9 insertions, 6 deletions
diff --git a/packages/matchbox2/matchbox-panel-2_svn.bb b/packages/matchbox2/matchbox-panel-2_svn.bb
index 1a92be3e37..44d23e1a55 100644
--- a/packages/matchbox2/matchbox-panel-2_svn.bb
+++ b/packages/matchbox2/matchbox-panel-2_svn.bb
@@ -1,19 +1,21 @@
DESCRIPTION = "matchbox-panel-2 is a lightweight dock (system tray) application based on Gtk+"
LICENSE = "GPL"
SECTION = "x11/panels"
-DEPENDS = "gtk+"
-
-RREPLACES = "matchbox-panel"
-
+DEPENDS = "gtk+ apmd startup-notification"
PV = "0.1+svn${SRCDATE}"
-PR = "r2"
+PR = "r8"
SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
S = "${WORKDIR}/${PN}"
inherit autotools pkgconfig
-EXTRA_OECONF = "--disable-startup-notification --disable-libnotify"
+EXTRA_OECONF = "--enable-startup-notification --disable-libnotify"
+
+# matchbox-<anything>-2 aims to replace their -1 counterpart, but at this point in time it's unfinished and unusable, so make it parallel installable
+do_install_append() {
+ mv ${D}${bindir}/matchbox-panel ${D}${bindir}/matchbox-panel-2
+}
do_stage() {
autotools_stage_all
@@ -21,4 +23,5 @@ do_stage() {
PACKAGES += "${PN}-applets"
FILES_${PN}-applets = "${libdir}/matchbox-panel/lib*.so* ${datadir}/*"
+FILES_${PN}-dev += "${libdir}/matchbox-panel/lib*.a ${libdir}/matchbox-panel/lib*.la"