aboutsummaryrefslogtreecommitdiffstats
path: root/packages/matchbox-wm/matchbox-wm_0.9.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/matchbox-wm/matchbox-wm_0.9.3.bb')
-rw-r--r--packages/matchbox-wm/matchbox-wm_0.9.3.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/matchbox-wm/matchbox-wm_0.9.3.bb b/packages/matchbox-wm/matchbox-wm_0.9.3.bb
index e69de29bb2..9bf7be1e69 100644
--- a/packages/matchbox-wm/matchbox-wm_0.9.3.bb
+++ b/packages/matchbox-wm/matchbox-wm_0.9.3.bb
@@ -0,0 +1,31 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Matchbox window manager"
+LICENSE = "GPL"
+DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat gconf matchbox-common"
+RDEPENDS = "matchbox-common"
+PR = "r1"
+
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/0.9/matchbox-window-manager-${PV}.tar.gz"
+
+S = "${WORKDIR}/matchbox-window-manager-${PV}"
+
+inherit autotools pkgconfig
+
+FILES_${PN} = "${bindir} \
+ ${datadir}/matchbox \
+ ${sysconfdir}/matchbox \
+ ${datadir}/themes/blondie/matchbox \
+ ${datadir}/themes/Default/matchbox \
+ ${datadir}/themes/MBOpus/matchbox"
+
+EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm"
+
+pkg_postinst() {
+update-alternatives --install ${bindir}/x-window-manager x-window-manager ${bindir}/matchbox-session 10
+}
+
+pkg_postrm() {
+update-alternatives --remove x-window-manager ${bindir}/matchbox-session
+}
+