aboutsummaryrefslogtreecommitdiffstats
path: root/packages/madfu/madfu_1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/madfu/madfu_1.2.bb')
-rw-r--r--packages/madfu/madfu_1.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/madfu/madfu_1.2.bb b/packages/madfu/madfu_1.2.bb
new file mode 100644
index 0000000000..be94f4e13b
--- /dev/null
+++ b/packages/madfu/madfu_1.2.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Firmware loader for m-audio devices"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://heanet.dl.sourceforge.net/sourceforge/usb-midi-fw/madfuload-1.2.tar.gz \
+ file://autofoo.patch;patch=1"
+inherit autotools
+
+S = ${WORKDIR}/madfuload-1.2
+
+#EXTRA_OECONF = "--without-udev"
+FILES_${PN} += "${libdir}/firmware/"
+
+do_configure() {
+ oe_runconf
+}
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -m 755 ${S}/madfuload ${D}/${sbindir}
+ install -d ${D}/${libdir}/firmware
+ install -m 644 ${S}/*.bin ${D}/${libdir}/firmware
+ install -d ${D}/${sysconfdir}/udev/rules
+ install -m 644 ${S}/42-madfuload.rules ${D}/${sysconfdir}/udev/rules
+}