aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux/mainstone-kernel_2.6.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux/mainstone-kernel_2.6.18.bb')
-rw-r--r--packages/linux/mainstone-kernel_2.6.18.bb31
1 files changed, 9 insertions, 22 deletions
diff --git a/packages/linux/mainstone-kernel_2.6.18.bb b/packages/linux/mainstone-kernel_2.6.18.bb
index f487e1f38a..290bb5911d 100644
--- a/packages/linux/mainstone-kernel_2.6.18.bb
+++ b/packages/linux/mainstone-kernel_2.6.18.bb
@@ -1,37 +1,24 @@
+require linux.inc
+
SECTION = "kernel"
DESCRIPTION = "Linux kernel for the Mainstone (PXA270 ref design)"
LICENSE = "GPL"
-PR = "r0"
+PR = "r2"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2 \
- file://mainstone_defconfig"
+ file://flash-unlock.patch;patch=1;pnum=0 \
+ file://defconfig"
S = "${WORKDIR}/linux-2.6.18"
COMPATIBLE_HOST = 'arm.*-linux'
-inherit kernel
-inherit package
-
ARCH = "arm"
-#CMDLINE_CONSOLE ?= "ttyS0,115200n8"
+
+CMDLINE_CONSOLE ?= "ttyS0,115200n8"
#CMDLINE_ROOT = "root=/dev/slug rootfstype=ext2,jffs2 initrd=0x01000000,10M mem=32M@0x00000000"
-#CMDLINE_ROOT = "root=/dev/mtdblock4 rootfstype=jffs2 mem=32M@0x00000000"
#CMDLINE_ROOT = "root=/dev/ram0 rw rootfstype=ext2,jffs2 initrd=0x01000000,10M init=/linuxrc mem=32M@0x00000000"
-#CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_CONSOLE}"
-
-do_configure_prepend() {
- install -m 0644 ${WORKDIR}/${MACHINE}_defconfig ${S}/.config
-# echo "CONFIG_CMDLINE=\"${CMDLINE}\"" >> ${S}/.config
-}
-
-do_deploy() {
- install -d ${DEPLOY_DIR_IMAGE}
- install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${MACHINE}-${DATETIME}.bin
-}
-
-do_deploy[dirs] = "${S}"
-
-addtask deploy before do_build after do_compile
+CMDLINE_ROOT = "root=/dev/mtdblock2 rootfstype=jffs2 console=ttyS0,115200 mem=64M"
+CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_CONSOLE}"
COMPATIBLE_MACHINE = "mainstone"